How to remove the presistant KDE wallet message that sometimes pops up?

I sometimes get this message upon starting up my PC
image

And it wants me to fill in the password in order to connect to my wifi modem. Is there a way to get this to stop asking me and to connect automatically on KDE plasma for EndeavourOS?

To disable the KDE wallet :

  1. (1) go to the KDE menu.
  2. (2) Type wallet , this will show KWalletManager .
  3. (3) Goto settings.
  4. (4) Uncheck " kwallet system active" .
2 Likes

Sorry mate it is not searching up for some weird reason, do you know another way?

7

You could also edit file ~/.kde/share/config/kwalletrc : adding to [Wallet] section just one line

Enabled=false

would disable kwallet popups.

If you have ~/.config/kwalletrc file, do the same with it.

2 Likes

After that you need somebody smarter than me to help :slight_smile: Good Luck

1 Like

Well it’s not doing that on my KDE setup and i have Chromium and Firefox installed. Konqueror is installed but i dare launch it because it’s probably the culprit. :stuck_out_tongue_winking_eye:

1 Like

@unix_lover
https://wiki.archlinux.org/index.php/KDE_Wallet#Unlock_KDE_Wallet_automatically_on_login

1 Like

I think I’ve stumbled on the answer your looking for… Open your wifi connection…
Choose the wifi-security tab… Choose store password (Non Encrypted) option…
give that a try…

2 Likes

Lets hope that works the next time I boot in.

System settings -> Account Details… uncheck Enable the KDE wallet subsystem

1 Like

Account details exists but there is no uncheck Enable the KDE wallet thing.

there is in Plasma 5.18.3, under the Wallet Preferences TAB

1 Like

Hello, everyone. I am so grateful because EndeavourOS seems to be awesome for me after installation as a main system in lieu of Windows. Previously, I was trying it only in WMWare in Windows. Using Linux as a main system is not really common in Korea except for some programmers and Ubuntu is popular than other linux distributions, but I preferred to try Linux and I have believed that I can meet really user-friendly Linux distributions someday. Anyhow, I really appreciate mlayland’s reply because I could remove the same annoying pop-up, which was so stressful for me, with his/her instruction. There was no such a KDE setting menu for my EndeavourOS (Plasma 5.23.4) as well. I could find the file of “kwalletrc” in the folder of “./config/”, which was hidden, in my home folder. I changed one sentence from “First Use=false” to “Enabled=false”. Then, it is gone. Thank you again :smiley:

The KDE wallet will be unlocked automatically if your passwords match and kwallet-pam is installed.

That is generally a better solution than disabling it as kwallet is used to store your secrets encrypted.

5 Likes

Thank you for your recommendation. Happy weekend :smile: