How to prevent network connection from jumping?

HP Laptop 15s-eq1xxx
Kernel: 6.1.39-3-lts
Desktop: KDE Plasma
v: 5.27.7 Distro: EndeavourOS

my laptop is connected via WiFi to the internet. There is a router and a repeater that is connected to the router via WiFi. When my laptop is not far from the router the signal strength of the connection is good, better than from the repeater. At a certain distance, the repeater signal is still very good, but the router signal is very meager. So, I choose in the panel’s “Networks” app the connection with the repeater; this is fine during my session.

But after a “Shut Dow” and fresh start of the laptop and Plasma, my nework connection jumps again to the weaker router signal and I have to connect again manually wth the stronger repeater signal.

How can I force Pasma to stick to the connection I chose manually, please?

Can you not go into the network settings and uncheck the box to connect automatically on the connection you don’t want to use?

1 Like

Thank you! I found the option “Connect automatically with priority” - “0”. Unchecked the option, and will see.