How to move window menu to window in KDE

I am trying to move the window menu from the application launcher to the window it self. I have not had good results searching for this on the web, so I thought someone here might know where to look or point me to the correct setting.
Picture to explain

It doesn’t show up in the panel like that by default. What did you do to enable that functionality in the first place?

There are a few different appmenu widgets I think.

Also, I don’t think system-settings will have the menu where you are pointing but other applications may.

Well, I changed the main theme to begin with, and while I was finding “my” preferred look, the taskbar moved to the top and the menu got “stuck” there. I am currently on Breeze Dark theme, but I have no idea how to get that menu back to the window.

Current plasma theme is “Gently” (main theme breeze dark and plasma theme gently), but I don’t see where I could change the settings within that.

I am pretty sure this is either buried within a menu or somewhere in a script.
I have been looking around within kvantum settings…
I know this is possible, just don’t know where I can find the settings/script

Try editing the panel and removing that widget/plasmoid from the panel.

I know how to get it from the panel, the problem is to add it to the windows :smiley:

It is often the widget itself which removes it from the window so sometimes removing it is all you need to do.

Also, not all applications have menus. Make sure you are testing with something like kate which has a menu. The example you are showing above, doesn’t have a menu normally.

Yeah, I have Okular (and few other which have menues) open and I am trying to get the menu to appear on it…

This is fun

My current work around is to add hamburger menu

settings -> look and feel -> window decorations -> buttons 

Not exactly what I want, but like I said, it is a work around.

No. It is the standard way of adding the menu (or anything) on the Window Title (Decorations).
You may confuse this with the other Plasma applications (not all applications, nor all Plasma ones) feature.
For those Plasma apps that support it, there is either a menu entry to Hide the menu, or a shortcut (default: Ctrl+M).


I have tried so many main themes, plasma themes and it got changes somewhere in that process. I have the look and feel that I want, so this is minor setback.

1 Like

You’ve done too much customisation and messed it up :rofl:

It’s easy to revert it though.

Go to System Settings → Appearance → Global Theme.

Select Breeze or Breeze Dark (only one of these two, don’t select some other theme you may have installed). If a window pops up check all the boxes and click Apply, if not, click on the Defaults button on the bottom of the window and then check all the boxes and click Apply.

This should restore the default look of Plasma. You may need to reboot, if things are really messed up.

Breeze Dark is my global theme (and yes I did select to apply to all), which is why I don’t know why I don’t get the menues on the windows. :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.