How to keep volume on in system tray?

I’m having a minor issue after installing pamac-all 9.5.12.
The volume that controls the sound in system tray is turned-off by default. Volume

I can easily turn it on, but when you restart the computer it’s off again no matter what you do. I didn’t have this issue with the pamac-git version. Any idea as how to keep it on after a restart?
System:
Kernel: 5.4.72-1-lts x86_64 bits: 64 compiler: gcc v: 10.2.0
Desktop: KDE Plasma 5.20.1 Distro: Arch Linux

This tip at the Arch Wiki should fix your issue

1 Like

What is pamac-all doing to disable audio? The two things should be unrelated.

Is this something to do with snapd ?

Nothing has worked so far. The volume is still off when I restart.

Did you try removing pamac-all, and any other packages it brought in as dependencies?

try this … if you have sound problem

Not yet. Should remove pamac-all and reinstall the pamac-gtk?

Why not try limiting the changes to a small number and approaching this systematically rather than to try changing everything at once?

If you think this is due to pamac-all then you can begin to narrow that down by removing that package and see if that actually makes a difference.

I tried that, but it goes back to off after a restart.

so you say it not auto mute problem?

The volume is muted when you turn on or restart the computer. I can easily turn it on, but it should be on by default.

did you save setting as root ? as detailed in that link ?

No, how do save the settings as root?

Add this script to startup:

#!/bin/bash
amixer -D pulse set Master 100%
1 Like

I can’t type the command in the Autostart. I can add an application, but no place for me to type the command.

Not a KDE user myself, but this might help

That should do it!

To OP - looks like you can edit a .desktop file add in the command parameters you want (in the (Exec= line), or write a simple bash script to set it up and run it as you want. The location will be as stated in the link. Have fun!

1 Like
  • Open an editor
  • Copy and paste the script from above
  • Save the script
  • Make executable chmod +x name-of-script
  • Open settings
  • “Add a login script”
  • Reboot or log out/in to test
1 Like

if auto mute problem …

"To save your current settings as the default options, run alsactl store as root. "

@xircon
I ran the script, but I made it executable by right clicking on the script , and then > permissions > Is exectutable.
I didn’t know how to make it executable by “chmod +x name-of-script”.
Then I added to the start-up and reboot, but it didn’t work. It was still muted after a startup.

@Shjim
I don’t have the auto mute Mode on my amixer.

I also tried this command with no success.

amixer -c 0 sset “Auto-Mute Mode” Disabled

amixer: Unable to find simple control ‘Auto-Mute Mode’,0
Also is this a Plasma 5.20 bug?