How to keep hdmi [data] from going to sleep

Hopefully simple to do but I can’t seem to find out how.

Configuration, on a [great] little asus pn51, I use the display port to drive my large primary screen, and I put an hdmi->hdmi+audio (spdif) which I connect to my HiFi 5.1 receiver.

That works great until I’m not typing for a while, and when my primary screen goes to sleep, my music is cutoff :frowning:

Is there a way to selectively enable sleep mode by output device?
That is HDMI-A-0 sleep mode off; DisplayPort-0 sleep mode on…


Hi @richard ,
Are you on Plasma?
In Advance power settings / Other settings uncheck Pause media players when suspending.
Although I understand your wish to find a selective HDMI port handling, I only tested a TV on HDMI with this config:

That was the first thing I did, long ago… before I switched to audacious, I believe there was also a VLC configuration setting which didn’t do anything special either.
BTW, for me, it was found under other parameters in the Plasma Advanced configuration settings.
I’ll see if the monitor can shut itself down on the display port if I turn off energy saving for the screen(s).

Are you not able to disable sleep on the primary screen in power management?

Yes, but my cats (who sleep in the room serving as home office) came to me red-eyed and seriously complained about the huge screen staying illuminated all night!
In other words, neither works.
It seems clear there needs to be a means to select which HDMI devices should be managed sleep wise or not.
Is this a purely KDE issue, or is it managed by the Linux subsystem?

Can you explain to me what the hdmi is hooked to? It is hdmi in on the converter from what? And then are you using Hdmi out? Or the spdif out to connect to the stereo. You said your primary screen is hooked to Display Port? Do you have only one display?

Yes i know what cats can get into. Maybe they are playing games with you?

Yes, only one large screen display on DisplayPort-0.
HDMI-A-0 out to hdmi/spdif converter to hifi (unfortunately the pn51 doesn’t have spdif out :frowning: )

The cats are always playing games where I’m the last to catch on :crazy_face:

So the hdmi out from the Asus pn51 is a graphics output? but is using the audio and is hooked to the converter which goes to the Stereo. So the audio cuts out because the hdmi goes to sleep? And the display port stays on and the monitor won’t sleep? Does the pn51 have display port out also? Or are you using the hdmi to display port with an adapter?

Edit: Not sure i understand exactly what the issue is? :thinking:

Edit: Is DPMS enabled for your monitor?

In theory, no… only audio… no graphics, but it does show up as thus

(I need to keep it active, else it’s cut off)

xrandr gives the following:

$ xrandr
Screen 0: minimum 320 x 200, current 4080 x 1440, maximum 16384 x 16384
HDMI-A-0 connected 640x480+3440+0 (normal left inverted right x axis y axis) 16mm x 9mm
   1280x720      60.00 +  50.00    59.94  
   1920x1080     60.00    59.94  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       60.00    59.94* 
DisplayPort-0 connected primary 3440x1440+0+0 (normal left inverted right x axis y axis) 797mm x 334mm
   3440x1440     59.97*+ 143.97   119.99    99.98  
   2560x1440    143.97   120.00    59.95  
   1920x1200     59.97  
   1920x1080    143.98   120.00   119.88    60.00    60.00    50.00    59.94  
   1600x1200     59.97  
   1680x1050     59.95  
   1280x1024     75.02    60.02  
   1440x900      59.89  
   1280x960      60.00  
   1280x800      59.81  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
DisplayPort-2 disconnected (normal left inverted right x axis y axis)

The pn51 has displayport, hdmi and usb-c displayport connectors, the last is unused.

The issue is seemingly the impossibility to select which screen outputs should go to sleep, all outputs go to sleep… meaning after a few minutes my music always stops… which is a PITA when you want to listen tranquilly to some music without blasting away on the keyboard.

What does this show

xset q
1 Like

Did you try with this?

1 Like

Also did you set pulse audio volume control to be using HDMI?

1 Like
$ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  600    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
DPMS (Display Power Management Signaling):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
1 Like

Just checked Xorg.0.log, here’s the corresponding snippet:

[    14.771] (II) AMDGPU(0): EDID for output HDMI-A-0
[    14.771] (II) AMDGPU(0): Manufacturer: EXP  Model: 901  Serial#: 1
[    14.771] (II) AMDGPU(0): Year: 2004  Week: 0
[    14.771] (II) AMDGPU(0): EDID Version: 1.3
[    14.771] (II) AMDGPU(0): Digital Display Input
[    14.771] (II) AMDGPU(0): Max Image Size [cm]: horiz.: 115  vert.: 65
[    14.771] (II) AMDGPU(0): Gamma: 2.20
[    14.771] (II) AMDGPU(0): DPMS capabilities: Off

Not sure there is anything pulseaudio related left after the pipewire updates.
Unless there’s something in particular… hints?
Audio seems to be working just fine.

Just to mention I keep trying things here.
I’m beginning to believe it is either a driver problem or perhaps even a hardware limitation.

I have added the following file:

$ sudo cat /etc/X11/xorg.conf.d/10-monitor.conf 
Section "Monitor"
    Identifier "HDMI-A-0"
    Option "DPMS" "false"

And Xorg.0.log confirms that, but unfortunately it’s a noop.

Worse, explicitly putting to sleep my display port monitor with

$ xset dpms force off -display :0

cuts the music output on the hdmi port as well

Guess I’ll try with the display driver folks.