How to install the lts-kernel correctly?

I have tried to install the LTS kernel via sudo pacman -S linux-lts linux-lts-headers, but cannot get it to start. I find this in /boot:

[me@EOS ~]$ ll /boot/
total 152177
-rw-r--r-- 1 root root 81920 Feb 1 09:25 amd-ucode.img
drwxr-x--- 4 root root 1024 1 Jan 1970 efi
drwxr-xr-x 6 root root 4096 12 Dec 09:50 grub
-rw------- 1 root root 18188741 8 Feb 08:44 initramfs-linux.img
-rw------- 1 root root 47138415 8. Feb 08:44 initramfs-linux-fallback.img
-rw------- 1 root root 18171428 10. Feb 10:56 initramfs-linux-lts.img
-rw------- 1 root root 46260970 10. Feb 10:56 initramfs-linux-lts-fallback.img
-rw-r--r-- 1 root root 13038080 8. Feb 08:44 vmlinuz-linux
-rw-r--r-- 1 root root 12920864 10. Feb 10:56 vmlinuz-linux-lts

[me@EOS ~]$ uname -a
Linux EOS 6.7.4-arch1-1 #1 SMP PREEMPT_DYNAMIC Mon, 05 Feb 2024 22:07:49 +0000 x86_64 GNU/Linux

The started kernel is not the LTS version 6.6.16-1, but the current not-LTS.
Do I have to do anything else in addition to the installation?
I ran grub-mkconfig manually, but that didn’t help.


Welcome here! :smile:

Are you sure you’re using grub? By default a new install has systemd-boot.

If you use grub, did you run this:

sudo grub-mkconfig -o /boot/grub/grub.cfg

How exactly do you select the kernel to boot?

Yes, I had explicitly selected grub during the installation over half a year ago, as I never had any problems with it in my previous Linuxes.
I’ve found the LTS kernel not listed in /boot/grub/grub.cfg, so i tried your command sudo grub-mkconfig -o /boot/grub/grub.cfg.
That was the mistake! My sudo grub-mkconfig wasn’t enough due to the failing path to grub.cfg.


1 Like

PS: Due to various boot and other problems I want to reinstall EOS again in another partition, then I will use the standard systemd-boot.

I think you are missing the point. You can use grub or you can use systemd-boot. If you re-install the system with grub you can add the lts kernel on the install. If you are installing the lts kernel afterwords it depends on how you are installing it. There is the package akm which is a kernel manager that can install the lts kernel and headers. If you install the lts with pacman you have to install the headers as well. Then you would need to run the grub update command to have it in the boot menu.

It is possible to switch from GRUB to systemd-boot using this tutorial…

Hi JKMooney,I was going to post that link as well but in his words I read “other problems”.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.