How to install pamac-aur-git / pamac-all / pamac-all-git with pacman 6.0

Note: remove any libalpm12 or something like this package before.

Here are the steps for installing these versions of pamac. Every software is installed this way, using yay to shorten command line:

yay -G software-name
cd software-name
makepkg -sri
cd ..
  1. Grab and install archlinux-appstream-data-pamac for all pamac versions.

  2. For pamac-aur-git, grab and install:

  • libpamac
  • pamac-aur-git
  1. For pamac-all and pamac-all-git, grab and install:
  • snapd
  • snapd-glib
  • libpamac-full
  • pamac-all or pamac-all-git

Here are some screenshots:

First, pamac-aur-git and its about window:

AUR support for pamac-aur-git:

And support for snap, flatpak and AUR in pamac-all / pamac-all-git.

11 Likes

So yay -S pamac-aur-git won’t work? I didn’t install libalpm12(How to check? Edit: pacman -Q), well not intentionally anyhow lol. Thanks @FredBezies

It should work fine. It worked for me. Some people prefer to call makepkg directly and manually install AUR dependencies while others prefer to use a helper like yay. There is no right or wrong way to do it.

3 Likes

Much appreciated @dalto Thank you! :+1:t3:

Edit: Everything seems to have installed just fine, thanks @dalto @FredBezies :+1:t3: :+1:t3:

[dad@archlinux ~]$ pacman -Q pamac
pamac-aur-git 10.1.3.r0.gb7837bb-1

Now to update my kids Endeavour installs :+1:t3:

You’re welcome. I just done a step by step install in the first post. Just to be sure every package is built correctly.

2 Likes

Pamac is back now! Thanks @FredBezies

I’m only the packager. Most work was done by Philip Muller and Guinux from Manjaro team.

5 Likes

How does one enable flatpak for pamac-aur now? The flags in the previous PKGBUILD for enabling flatpak or snap are gone.

Err…they appear to be there for me.

Are you looking at pamac-aur-git because I don’t think that one had those flags.

Either way, you need to add -Denable-flatpak=true to the meson build options line. You also should either add flatpak as a dependency or just make sure you install it first.

1 Like

Ah, yes. I was using non-git before. Didn’t know the -git never had those flags. Thanks!

hello;thank you to read well, your answer is written

If you want flatpak, just use pamac-all or pamac-all-git package which libpamac-full as said in the first post.

I do not think flatpak or snap to be useful on a rolling release distributions, this is why I deactivate both universal package format on pamac-aur-git.

1 Like

Just updating didn’t work for me either. It aborted complaining that some files already exist (libalpm). So I removed everything pamac related (pamac-aur, pamac-tray-icon-plasma). After this, reinstalling the two packages using yay worked flawlessly.

Thanks. I just installed it with yay in the usual manner. Everything went smoothly and I didn’t have to do anything unusual.

I’m glad to have pamac-aur-git back but I think that I’ll be using bauh as my primary program to discover new programs.

Lawrence

1 Like

The “problem” with pamac is that it is developed with the delayed Manjaro update/upgrade schedule in mind. It may be good for Manjaro but for Arch & arch-based distros It has proved to be troublesome quite often.
For anyone who wants a gui standalone “software center” Bauh is (in my opinion) a more solid & troublefree solution.
That being said, my point is that EndeavourOS comes with an outstanding in-built update system, besides the pure, die-hard cli. I really have no other use for any gui update tools other than searching.
KISS & kisses… :enos_flag: :enos:

1 Like

I think I won’t ever be able to build pamac on this laptop, my eos install is just a couple of weeks old.
I couldn’t build it with pacman 5 and now still not with 6.
I guess I’ll have to wait for a binary again… :expressionless:

$ makepkg -sri
==> Pakket pamac-aur-git 10.1.3.r0.g8582762-1 (vr 11 jun 2021 16:22:59 CEST) wordt gemaakt
==> Uitvoerafhankelijkheden controleren...
==> Afhankelijkheden voor creatie controleren
==> Bronnen ophalen...
  -> pamac git repo klonen...
Cloning into bare repository '/home/richard/pamac-aur-git/pamac'...
remote: Enumerating objects: 1546, done.
remote: Counting objects: 100% (1546/1546), done.
remote: Compressing objects: 100% (282/282), done.
remote: Total 15476 (delta 1258), reused 1515 (delta 1243), pack-reused 13930
Receiving objects: 100% (15476/15476), 13.73 MiB | 246.00 KiB/s, done.
Resolving deltas: 100% (12797/12797), done.
==> Valideren van source bestanden met sha256sums...
    pamac ... Overgeslaan
==> Bronnen uitpakken...
  -> Een werkkopie van pakketlijst pamac git aan het aanmaken...
Cloning into 'pamac'...
done.
==> Bezig met het uitvoeren van prepare()...
==> Bezig met het uitvoeren van pkgver()...
==> Bijgewerkte versie: pamac-aur-git 10.1.3.r0.gb7837bb-1
==> Bezig met het uitvoeren van build()...
The Meson build system
Version: 0.58.1
Source dir: /home/richard/pamac-aur-git/src/pamac
Build dir: /home/richard/pamac-aur-git/src/pamac/builddir
Build type: native build
WARNING: Unknown options: "enable-appindicator"
The value of new options can be set with:
meson setup <builddir> --reconfigure -Dnew_option=new_value ...
Project name: pamac
Project version: 10.0
C compiler for the host machine: cc (gcc 11.1.0 "cc (GCC) 11.1.0")
C linker for the host machine: cc ld.bfd 2.36.1
Vala compiler for the host machine: valac (valac 0.52.4)
Host machine cpu family: x86_64
Host machine cpu: x86_64
Found pkg-config: /usr/bin/pkg-config (1.7.3)
Program glib-compile-resources found: YES (/usr/bin/glib-compile-resources)
Program glib-compile-resources found: YES (/usr/bin/glib-compile-resources)
Program glib-compile-resources found: YES (/usr/bin/glib-compile-resources)
Found pkg-config: /usr/bin/pkg-config (1.7.3)
Run-time dependency gobject-2.0 found: YES 2.68.2
Run-time dependency gio-2.0 found: YES 2.68.2
Run-time dependency libsoup-2.4 found: YES 2.72.0
Run-time dependency polkit-gobject-1 found: YES 0.119
Run-time dependency libnotify found: YES 0.7.9
Run-time dependency appstream-glib found: YES 0.7.18
Run-time dependency gio-unix-2.0 found: YES 2.68.2
Run-time dependency pamac found: YES 11
Run-time dependency gtk+-3.0 found: YES 3.24.29
Run-time dependency libhandy-1 found: YES 1.2.2
Run-time dependency gmodule-2.0 found: YES 2.68.2
Library posix found: YES
Library m found: YES
Configuring org.manjaro.pamac.manager.service using configuration
Program a2x found: YES (/usr/bin/a2x)
Program gzip found: YES (/usr/bin/gzip)
Build targets in project: 15

Found ninja-1.10.2 at /usr/bin/ninja
[7/49] Generating pamac.conf.5 manpage with a custom command
FAILED: data/doc/pamac.conf.5 
/usr/bin/a2x -f manpage -D data/doc ../data/doc/pamac.conf.5.asciidoc
a2x: ERROR: "xmllint" --nonet --noout --valid "/home/richard/pamac-aur-git/src/pamac/builddir/data/doc/pamac.conf.5.xml" returned non-zero exit status 4

[8/49] Generating pamac.8 manpage with a custom command
FAILED: data/doc/pamac.8 
/usr/bin/a2x -f manpage -D data/doc ../data/doc/pamac.8.asciidoc
a2x: ERROR: "xmllint" --nonet --noout --valid "/home/richard/pamac-aur-git/src/pamac/builddir/data/doc/pamac.8.xml" returned non-zero exit status 4

[9/49] Compiling Vala source ../src/tray.vala ../src/tray-gtk.vala
../src/tray-gtk.vala:23.3-23.28: warning: `Gtk.StatusIcon' has been deprecated since 3.14
../src/tray-gtk.vala:26.22-26.35: warning: `Gtk.StatusIcon' has been deprecated since 3.14
Compilation succeeded - 2 warning(s)
[11/49] Compiling Vala source ../src/transaction...ala ../src/version.vala ../src/local_config.vala
ninja: build stopped: subcommand failed.
==> FOUT: Er is een fout opgetreden in build().
    Afbreken...

Are you not able to install pamac with

yay -S pamac-aur-git

4 Likes

question … how many pamac.conf you have in /etc ?

Edit if have old " archlinux-appstream-data-pamac " try remove . just help friend that use pamac ( i no use )

that stop her install . once removed it install ok
just idea as your different language

No.