How to install Odoo community edition

There is a Odoo aur package but unfortunately the python requirement is not satisfied. So what is the solution, downgrade python to 3.19 ?

yay odoo                                                                                              {long_cmd_duration}
10 aur/algodoo-wine 2.1.0-1 (+0 0.00) 
    A unique 2D-simulation software from Algoryx Simulation AB (Using Wine).
9 aur/python2-openupgradelib 1.3.2-1 (+0 0.00) (Orphaned) (Out-of-date: 2022-02-12) 
    A library with support functions to be called from Odoo migration scripts.
8 aur/python-pylint-odoo 1.8.2-2 (+0 0.00) 
    Pylint Odoo plugin
7 aur/python-odoorpc 0.8.0-1 (+0 0.00) 
    Python module providing an easy way to pilot your Odoo servers through RPC.
6 aur/python2-oerplib 0.8.0-1 (+1 0.00) 
    Python module providing an easy way to pilot your OpenERP and Odoo servers through RPC
5 aur/etherpuppet v0.4-3 (+1 0.00) 
    Small program that will create a voodoo doll for an Ethernet interface
4 aur/algodoo 1.x.x.latest-5 (+12 0.06) 
    A physics simulator program for education and fun (based on phun)
3 aur/odoo 15.0-1 (+56 0.28) 
    Web-based Open Source Business Apps
2 extra/xf86-video-voodoo 1.2.5-12 (14.9 KiB 30.6 KiB) [xorg-drivers] 
    X.org 3dfx Voodoo1/Voodoo2 2D video driver
1 extra/perl-crypt-random-tesha2 0.01-7 (15.7 KiB 22.9 KiB) 
    Random numbers using timer/schedule entropy, aka userspace voodoo entropy
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 3
 -> Could not find all required packages:
	python<=3.9 (Wanted by: odoo)

i also tried to run from source file inside of virtualenv and i get struck up in greenlet.

1 Like

You can’t practically downgrade Python without breaking things.

Can you run it in a container?

1 Like

Hi @pannet1

Firstly, This is not a community package but a package from the AUR. I have corrected the title for you so people can better assist you. Looking at the comments you are not alone in this and it appears to indeed be a python related issue. Your best bet might be to message the maintainer for a resolution. You might get lucky and someone else is using this AUR package here but it could take some time for someone to come along.

EDIT

See post #11

1 Like

Some of the solutions on the AUR page for this package look really sketchy…

I was also reading that only, it looks like there is incompatibility with python 3.10.

https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1833838.html

1 Like

so it seems docker is the final option

“Community Edition” describes the version of Odoo he is trying to install. It has nothing to do with the repo.

Honestly, a container of some sort is usually the best way to run server software like that on Arch-based distros. It is too hard to control the versions otherwise.

Where did you divine that information?

AUR (en) - odoo (archlinux.org)

On their website?

It is also a fairly common convention for this type of software.

1 Like

it was intended to differentiate the enterprise version of odoo (differences mentioned in their website)

Ahh…I see now I have zero exposure to this type of software and their web site is firewalled off from where I am at. As usual I was only referencing what can be found from upstream arch ie the arch AUR page.

Just for any other new to arch linux based distro users out there that do not want to click that link for this packages website they have two versions a community version and an enterprise version. This should not be confused with the community repository of Arch. If the OP had not mentioned this is an AUR package in the post the title can be misleading.

:hugs:

@Elloquin @dalto
How much care you take for the (EOS) community ! It is mind boggling. Amazing guys

2 Likes

Sir, on Github website, it is mentioned that editng requirements.txt solves the issue.
I am not able to do it, hence I asked you.

I’d definitely stick to the docker versions. I ran an odoo docker instance without any problems for about two years; then made a switch to erpnext (no enterprise vs. community versions bulls#; all inclusive and open source).

2 Likes

that was two years before.
right now, installation failed due to greenlet and changed the requirements.txt to accomodate the latest greenlet and yet i have some issues.

note: greenlet issue is solved based on the developer’s advise. see first post.

i took the same path but unfortunately the market demand atleast in my locality is for odoo. many people choose enterprise edition if it demands lot of customization (so that you end up less customizing) and community edition if less customization is need.
if you are looking for the specific killer feature from enterprise then there is option to buy plugins from individual developers.