How to install minimal Gnome DE? (How to Convert Arch Linux to EndeavourOS)

As the title says how do I go about doing it? On Arch I do sudo pacman -S gnome then select the packages I need from the group (except for dependencies like cheese which I have no control over). But the calamares installer only has a few boxes to tick but still get so many apps I don’t need.


Are you sure that when you install gnome on vanilla Arch it is different than gnome of EndeavourOS?

If so, perhaps you could do an EndeavourOS installation without a DE, and then sudo pacman -S gnome as you would on Arch. It pulls the packages from the same repos.

I did it in a rush because I just wanted to check EndeavourOS first before commiting. I’m dowloading the ISO right now to do a fresh install again. I still haven’t commited but I think I will move to EndeavourOS once these minor issues are solved. Reason is I prefer your community.

I actually opened a seperate topic about replacing grub with systemd. Is it possible to install EndevaourOS on command line like you would with Arch? Maybe it would solve the grub issue as well because I can just setup systemd-boot.

Yes, while I haven’t tried it myself, I believe it is entirely possible, and it shouldn’t be any different from installing vanilla Arch.

The only significant difference between vanilla Arch and EndeavourOS is the addition of the endeavouros repository, which contains some useful utilities that are not in the official Arch repos, that make your life a bit easier. You could add that repo manually to a vanilla Arch installation and then you would, effectively, have EndeavourOS.

1 Like

Serious? So all I have to do is just add the repo? Man then I’ll just do that cos I’m more comfortable doing it that way. I just prefer this community. So then once that repo’s been added I can do sudo pacman -S yay :slight_smile: and done.

Exactly! :smiley:

You should also install the following, for a fuller EOS experience:

1 Like

Thanks @Kresimir :slight_smile: I’m gonna try and see if I can do a cli install with the EndeavourOS ISO if not I’ll do an Arch install. Also, if I do it with the EndeavourOS ISO I have to refresh the keys right?

ps-I don’t like the purple theming of EndeavourOS :woozy_face: I prefer dark backgrounds

Yes. If you do the cli install from the EndeavourOS ISO, the base package is called eos-base and it is in the endeavouros repo. I think you have to install that one.

Btw what’s the repo URL?


Is this it?

SigLevel = PackageRequired
Server =

I have these in my /etc/pacman.d/endeavouros-mirrorlist:

## Germany
Server =$repo/$arch

## Sweden
Server =$repo/$arch
Server =$repo/$arch

## Github
Server =
Server =$repo/$arch

And in /etc/pacman.conf

SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

Thanks. I will just have to change the mirrors with something close to home. I mentioned the one for Calamares :man_facepalming:

Well, just get it working, then you can pacman -S endeavouros-mirrorlist and it will be managed for you automatically.

1 Like

I will, Thanks. I will update you soon. It’s dinner time so prolly gonna be about an hour or so before I could do it.

Good luck, let me know how it went.

If you have any problems, @jonathon wrote an excellent guide on how to convert Manjaro to EndeavourOS, the same procedure (even simpler) should apply to converting vanilla Arch to EndeavourOS.

1 Like

Certainly. I will have a look at that guide as well. Thanks so much for your time.

1 Like

Do I have to do this?

Also, do I leave the Arch mirrorlist file in /etc/pacman.d ? or replace it with endeavouros-mirrorlist?

Edit: I’ll answer myself yes because I endeavouros-mirrorlist is for the extra packages the rest are pulled in from arch repos

1 Like

Well it seems to work fine except when I installed eos-hooks I got the following error

sed: can’t read /etc/lsb-release: No such file or directory

All I did was add the following entry in pacman.conf

SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

Then created a file named endeavouros-mirrorlist in pacman.d

Then just did a pacman -Syu

I also ran the following;

sudo pacman-key --keyserver -r 003DB8B0CB23504F
sudo pacman-key --lsign 003DB8B0CB23504F

Then installed

Am I offficially on EndeavourOS now ? :face_with_raised_eyebrow:

Edit: Oh and I removed the manually created endeavouros-mirrolist file and replaced it with the installed one :slight_smile:

I would guess so. I have done this to a couple of Arch ‘metal’ installs, and it works well. In fact I added endeavouros repo to other Arch-based distros too - some of the tools are too good to operate without :grin:

Would be interested to hear what troubles were caused by rEFInd - as I mostly use it to avoid troubles! Also - because multi-boot…

1 Like