How to install EasyOS which only comes in .img in VirtualBox?

Hello everyone,
I am trying to install EasyOS in VirtualBox with EndeavourOS as the host.
The author of that distribution isn’t providing .iso files and renaming doesn’t work (VB can’t see the ISO).

I have tried:
VBoxManage convertdd easy-3.1-amd64.img easy-3.1-amd64.iso
but the resulting .iso image does not boot (Fatal boot error).

Any hints?

Does this help? It’s pretty step-by-step.


Thanks Stagger_Lee
I have opted to go for EndeavourOS XFCE instead. It’s light enough for running a local web development server.

1 Like

Be careful about using arch-based as web server. The php and mysql/mariadb versions are being kept to the latest release versions by frequent updates (which means php8.x). Not only does this mean your testing environment continuously changes, but most shared hosting providers (where sites usually get deployed) are still on php 7.4x, so it wont match the testing environment (if not using PHP, I assume the same concern is still valid for python or other languages you develop in).

Of course you can use package php74 or php7 from AUR (and some fiddling with the config files), or use docker or similar environments, however usually there are other distros recommended for headless web server duties with less frequent updates.

As @nate said it’s not advised to use an Arch-based distro to be used as a server. Because Arch and the distros based on it get updated frequently so the tendency to break things is high. So like to suggest you try Debian or Debian-based distro which are very stable. Or even one of the RHEL based ones like Rocky Linux or AlmaLinux OS.

Thank you nate and s4ndm4n,
I have spent several days with testing and learning on how to do this best and am amazed on how fragmented the information is. Indeed, as you guys state, it’s almost mandatory to use a Debian or Ubuntu solution.
Sadly, the tutorials (and I’ve watched a ton) are of poor quality where a lot of things are assumed which is typical for amateur teachers.

I am more and more inclined to put my years of teaching experience to work and start a YouTube channel for creative/productive people. This has been on my mind for a while now and I feels it’s the right thing to do.

so far, Ubuntu server gave me the best results but getting my duplicator (WordPress) files to install/run is a challenge. The easy way out would be to install a full-blown Ubuntu install which gives my a lot more tools to work with until I learn how to do this via the terminal only.

For development,

Generally, if you start a thread with what you’re trying to do, rather than how you think you should fix the problem, people will be able to give you a direct solution.

I rather advise against using that stack for Wordpress. Changing the PHP version on it is a huge pain and Wordpress constantly updates it’s PHP version requirements.

A plain Ubuntu install is the best in my experience. Also most of the know-how articles are written with Ubuntu in mind.

Try using wp-cli. You don’t need duplicator as it presents issues itself, environment notwithstanding.


  1. archive the files at the source and download the archive
  2. upload the archive and expand it at the destination
  3. export the database and import it at the destination
  4. run wp search-replace "//" "//" and you are done. wp-cli performs a smart replacement in the whole database, including serialized values.
1 Like

Why would you update PHP and Wordpress in a Wordpress development appliance rather than just replace the entire appliance?

I’ll give you an example where that is needed:
I develop and maintain a lot of Wordpress websites. For most of the sites, once deployed on the live server, I keep a copy on the development server, so I can test new updates and use as a staging instance for any changes I want to deploy on the live website. It would be a useless fuss to reinstall the Wordpress instance all WordPress instances on a new environment when i want to update the PHP version.

Thank again guys,
I think that it’s all working now.

I will try out what you suggested because I’m always interested in better ways but so far, Duplicator has always worked.
All in all, EndeauvourOS is now my main OS and the longer I use it, the more I appreciate it. Having a local mirror of my VPS is awesome and all the things I’ve learned lately might eventually help me to “downgrade” the Cloudways VPS once I am comfortable with the LAMPP stack.

I’ll pick your brilliant brains again If something unexpected pops up. Thank you! :slight_smile: