How to get rid of windows partition

I have a windows partition and want to get rid of it without having to reinstall EndeavourOS. I am not exactly sure how to do this any input would be appreciated

1 Like

Could you post a screenshot of your disk? And maybe the terminal output of sudo parted -l.

Please add output of

inxi -Fazy
sudo efibootmgr -v

sudo parted -l

Model: ATA SanDisk SDSSDH35 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 106MB 105MB fat32 EFI system partition boot, esp
2 106MB 123MB 16.8MB Microsoft reserved partition msftres
3 123MB 105GB 105GB ntfs Basic data partition msftdata
6 105GB 493GB 388GB ext4
5 493GB 500GB 6291MB linux-swap(v1) swap
4 500GB 500GB 530MB ntfs hidden, diag

1 Like

inxi -Fazy gives me command not found
and
sudo efibootmgr -v
gives me a list of every os that has ever been on my system

/dev/sda3 and /dev/sda4 can be made unallocated space by Gparted.

1 Like

It looks like you are sharing the same ESP (/dev/sda1) between EnOs and Win. Keep that and remove the others as mentioned above by @Leon.

:turtle:

edit: sda2 could be deleted as well.
edit2: you have backed up your personal data from your Windows? Just wanted to double-check.

1 Like

Thank you for your help. There was no personal Data in windows just one game that I finally got to work on EndeavourOS. You all have been great

3 Likes

you need to install inxi first to get the command works, it’s not installed by default

sudo pacman -S inxi

1 Like

inxi -Fazy
System:
Kernel: 5.8.9-arch2-1 x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-linux
root=UUID=7da0b135-ecda-4031-af51-af278dcebbcc rw quiet loglevel=3
nowatchdog
Desktop: Cinnamon 4.6.7 tk: GTK 3.24.23 dm: LightDM 1.30.0
Distro: EndeavourOS
Machine:
Type: Laptop System: ASUSTeK product: GL503VD v: 1.0 serial:
Mobo: ASUSTeK model: GL503VD v: 1.0 serial:
UEFI: American Megatrends v: GL503VD.310 date: 04/29/2019
Battery:
ID-1: BAT1 charge: 54.9 Wh condition: 54.9/64.4 Wh (85%) volts: 5.2/15.2
model: ASUS A32-K55 type: Li-ion serial: N/A status: Full
CPU:
Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP
arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: D6
L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 44817
Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
4: 800 5: 800 6: 800 7: 800 8: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:591b
Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK
driver: N/A alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0
chip ID: 10de:1c8d
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus ID: 1-7:4 chip ID: 13d3:5666 serial:
Display: x11 server: X.Org 1.20.9 driver: modesetting display ID: :0
screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4")
s-diag: 485mm (19.1")
Monitor-1: eDP-1 res: 1600x900 hz: 60 dpi: 118 size: 344x194mm (13.5x7.6")
diag: 395mm (15.5")
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.7
direct render: Yes
Audio:
Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 00:1f.3 chip ID: 8086:a171
Sound Server: ALSA v: k5.8.9-arch2-1
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: d000
bus ID: 02:00.0 chip ID: 10ec:8168
IF: enp2s0 state: down mac:
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: d000
bus ID: 04:00.0 chip ID: 8086:24fd
IF: wlan0 state: up mac:
Drives:
Local Storage: total: 465.76 GiB used: 38.73 GiB (8.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda vendor: Samsung model: SanDisk SDSSDH3500G size: 465.76 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial:
rev: 10RL scheme: GPT
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 port: f060 bus ID: 00:17.0 chip ID: 8086.282a rev: 31
Partition:
ID-1: / raw size: 459.29 GiB size: 451.08 GiB (98.21%)
used: 38.71 GiB (8.6%) fs: ext4 dev: /dev/sda6
Swap:
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 6.35 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda5
Sensors:
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:
Processes: 238 Uptime: 7m Memory: 15.52 GiB used: 1.10 GiB (7.1%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 970 lib: 282
flatpak: 0 Shell: Bash v: 5.0.18 running in: gnome-terminal inxi: 3.1.06