How to get as much info about the HardWare via Terminal?

hello dear community

how to get as much info about the HardWare via Terminal?

background - i installed Eos on desktop - but i am facing some weird issues with the graphics

in other words the machine did not show any screen content after 30 min.

after restarting - it showed all to big - in other words - it lost the whole graphic-setup.

so i need to get more infos - which graphic-card etc. etx . i run in this setup - for the further investigations…

are there any apropiate commands here - that help me here - eg. in listing up all the hw!?

look forward

btw: see here

this looks pretty funny - doesnt it.
the display data - /(pixel etc etx. of the monitor got lost fundamentally
i dunno why

note: i run a IIama pro-lite B2475HDS


btw: see even more

but well - it would be more apropiate - if i can run a command on terminal that gives me some data bout the graphic-card… is there a command that helps here!?

You can use inxi, here is the man page which you can retrieve in the terminal too.

The forum log/help tool top of the page link in forum brings you here


hi there - many many thanks i will run this coommand later .
at the moment i am right busy - but i will do this later the day and get some more infos.

many thanks

1 Like

Hi @otrott
As @Zircon34 indicated inxi command is powerful enough.
I myself use

inxi -Fxxx

To get all details I need about my system, the kernel,… etc.
I hope this helps.

1 Like

hi dear friends

see below what i have gotten…

[martin@martinsendeavour ~]$ inxi -Fxxx
 Host: martinsendeavour Kernel: 6.2.2-arch1-1 arch: x86_64 bits: 64
   compiler: gcc v: 12.2.1 Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8
   wm: kwin_x11 vt: 1 dm: SDDM Distro: EndeavourOS base: Arch Linux
 Type: Desktop Mobo: ASRock model: A320M-HDV R3.0
   serial: <superuser required> UEFI: American Megatrends v: P1.70
   date: 12/18/2018
 Info: quad core model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64
   type: MCP smt: <unsupported> arch: Zen rev: 0 cache: L1: 384 KiB L2: 2 MiB
   L3: 4 MiB
 Speed (MHz): avg: 1588 high: 1600 min/max: 1600/3500 boost: enabled cores:
   1: 1600 2: 1600 3: 1600 4: 1554 bogomips: 27956
 Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
 Device-1: AMD Tonga PRO [Radeon R9 285/380] vendor: PC Partner / Sapphire
   driver: amdgpu v: kernel arch: GCN-3 pcie: speed: 8 GT/s lanes: 8 ports:
   active: HDMI-A-1 empty: DP-1,DVI-D-1,DVI-D-2 bus-ID: 10:00.0
   chip-ID: 1002:6939 class-ID: 0300 temp: 31.0 C
 Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
   loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
   gpu: amdgpu display-ID: :0 screens: 1
 Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x202mm (10.63x7.95")
   s-diag: 337mm (13.28")
 Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Idek Iiyama PL2475HD
   serial: 11098M1B00099 res: 1024x768 dpi: 50 size: 521x293mm (20.51x11.54")
   diag: 598mm (23.5") modes: max: 1920x1080 min: 720x400
 API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon R9 380 Series (tonga
   LLVM 15.0.7 DRM 3.49 6.2.2-arch1-1) direct-render: Yes
 Device-1: AMD Tonga HDMI Audio [Radeon R9 285/380]
   vendor: PC Partner / Sapphire driver: snd_hda_intel v: kernel pcie:
   speed: 8 GT/s lanes: 8 bus-ID: 10:00.1 chip-ID: 1002:aad8 class-ID: 0403
 Device-2: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
   v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 38:00.6 chip-ID: 1022:15e3
   class-ID: 0403
 Sound API: ALSA v: k6.2.2-arch1-1 running: yes
 Sound Server-1: PulseAudio v: 16.1 running: no
 Sound Server-2: PipeWire v: 0.3.66 running: yes
 Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
   vendor: ASRock driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
   port: e000 bus-ID: 25:00.0 chip-ID: 10ec:8168 class-ID: 0200
 IF: enp37s0 state: up speed: 1000 Mbps duplex: full mac: 70:85:c2:b2:45:41
 Local Storage: total: 698.65 GiB used: 9.43 GiB (1.4%)
 ID-1: /dev/sda vendor: Samsung model: SSD 840 Series size: 232.89 GiB
   speed: 6.0 Gb/s type: SSD serial: S19MNEAD402833F rev: 8B0Q scheme: GPT
 ID-2: /dev/sdb vendor: Seagate model: ST500DM002-1SB10A size: 465.76 GiB
   speed: 6.0 Gb/s type: HDD rpm: 7200 serial: ZA41HDN8 rev: HPH3 scheme: MBR
 ID-1: / size: 227.21 GiB used: 9.36 GiB (4.1%) fs: ext4 dev: /dev/sda2
 Alert: No swap data was found.
 System Temperatures: cpu: 23.9 C mobo: N/A gpu: amdgpu temp: 32.0 C
 Fan Speeds (RPM): N/A gpu: amdgpu fan: 170
 Processes: 223 Uptime: 5m wakeups: 0 Memory: 7.69 GiB used: 1.53 GiB (20.0%)
 Init: systemd v: 253 default: graphical Compilers: gcc: 12.2.1 Packages:
 pm: pacman pkgs: 959 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.25
[martin@martinsendeavour ~]$

hmm guess that therer is something wrong here.

hmmm - on the way back to “normal” i think i have several options:

question: can this be helpful!?


Hi, I’m recently installed endeavouros xfce & I facing an critical issue!
I’m trying to changing my screen resolution using xrandr but when I shutdown->open my pc again it goes back to the previous state :sob:
before I was used ubuntu based distro, where I used these commands below to save screen configurations permanently…
**:~$** xrandr
**:~$** cvt 1280 1080
**:~$** sudo xrandr --newmode “1280x1080_60.00” 115.00 1280 1368 1496 1712 1080 1083 1093 1120 -hsync +vsync
**:~$** xrandr --addmode VGA-1 “1280x1080_60.00”
**:~$** gedit ~/.profile

now how can I do this same thing on endeavouros? there is no .profile file & I’ve tested… it doesn’t work on arch based distro :sweat:

well i think that i have to setup the resolution and afterwards i have to observe the “behaviour” of the system . - look if it is stable

at the moment i have fancy resolution

1 Like

I commonly use autorandr to save/retrieve my screen configs. Sometimes in combination to arandr to set the screen config.

1 Like

hi thank you
set this to 1280 to 800 (16:10 ratio)

and saved it.

now i will have a closer look if this is permanent and saved - even if i switch off the computer and re start it again .

What I normally do is just pull up my terminal and chose my named profile, for example

autorandr home

You can also load automatically your profile by using

autorandr --change

But would need to load that command at login. I think by adding it to your .x profile config file or similar.

For a readable browser output try:

sudo lshw -html > harware.html