How to get 150% scaling for 1920x1080 screen?

Before trying to make an Openbox installation with EnOS, I have to ask this. I just moved the Openbox system I had in an old laptop with 1366x768px (which is too slow), to a 1920x1080px newer laptop. The scaling is 1:1 and I can’t make it 125% or 150%. At least 125% would be very nice.

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm
   1920x1080     60.01*+  60.01    59.97    59.96    59.93

But, if I try,

$ xrandr --output eDP1 --scale 1.5x1.5
warning: output eDP1 not found; ignoring

Its been a long time since I used Openbox, and on a 1366x768px screen, everything looked alright. But on a 2k screen everything looks tiny. I installed Arandr, but don’t know how to use it.
Any help is appreciated.

-

:wink:

^^ Thanks.
I should’ve written ePD1, I should’ve written eDP-1, then xrandr --output eDP-1 --scale 1.5x1.5 works, only the screen become smaller.

But, if I write xrandr --output eDP-1 --scale 0.75x0.75, then screen becomes bigger.

1 Like

Correct. 1.5x increased the resolution by 1.5x which has the effect of things looking smaller on the same physical output.

Thanks!
I put it in the autostart file and restarted. The scaling stayed put. :slight_smile:

1 Like

It is so snappy!
I have to work with it for sometime to get the hang of it. Its been a long time since I used Openbox. I am sure there should be an EnOS Openbox version! :slight_smile:

2 Likes

Just to check scaling matter, I downloaded the EnOS 2021. In Settings > Display > Scale, if I click 1.5x, the screen resolution becomes smaller as in the post #3 above.


From the live iso

If I do the xrandr method, it works as should be.


Maybe this matter should be looked into.

That is a new ‘feature’ of XFCE 4.16 that I reported on the day it hit the repos! I expected the ‘view’ to grow in the same way that it does when choosing 2x scaling - but it went the opposite direction, increasing the ‘apparent resolution’ instead (shrinking the ‘view elements’). I believe other DE’s that have the capability (Gnome, Cinnamon), reverse this.

As noted, this can be overcome various ways. including setting the scale to 0.75 (or whatever) to get the larger ‘view elements’. In fact, in my case, I left the higher resolution screen alone (it was workable with the other tweaks I had done (increasing DPI and fonts sizes mainly) and set the secondary screen to 1.25 so that the view elements matched up better. In other words, the apparent resolution grew on the secondary, thus giving me more room to show conkys!

I’ve been keeping an eye on ‘news’ regarding this, and no-one seems to have noticed - so maybe only I was surprised…

I noticed it also and on KDE it is better because it has a global setting. I used 125% and is okay on my HP laptop. Windows automatically sets it at 150%

Is this on xfce? Instead of changing scaling in display you can also set the dpi under settings, appearance, fonts.

Yes, that’s xfce in live mode.
the dpi can be set from settings, but anyone would choose the display scaling, then might consider it is a bug.

I just pointed out that i use the dpi setting on my HP laptop as i run into the same problem because the screen is one of those HiDpi also. I don’t consider anything a bug really. Some desktops have these issues on these HiDpi monitors. Others are better at dealing with it. I don’t particularly like these hiDpi monitors anyway.

Most of the new laptops are 1920x1080px or above, so the 1:1 will give tiny fonts, tiny app windows, too hard to read. Most of the newcomers might think that as a bug, when the xfce settings manager scaling actually makes the screen look even tinier.

This is my first laptop and i only bought it because it is a Ryzen without any Hybrid Graphics so i didn’t have to deal with that. I knew it would be smaller but it’s different with every desktop like i said. Kde has a global setting which allows you to set 125% and Windows 10 that was installed on it has the default global setting set to 150%. Some of the desktops don’t deal very well with allowing you to change theses settings. I found that out very quickly. i3 and sway for instance and some others that i have tried. Xfce i use the dpi setting and i can make it work. I also can change fonts and such. It is what it is as this is something out of my control. I can only do what the software provides. So if i don’t like it then my choice is to switch to something that works better. :man_shrugging:

1 Like

I have EOS Plasma, and there I have 125%, which is there in the settings to choose. But, when I checked the EOS Xfce (default) in live mode, I found I cannot use the XFCE settings manager’s display scaling, which took me the other way, as I shown in #2 (in my Openbox system) and in #6 (EOS live). Clicking the scale to x1.5, it goes the other way (the linked script), most probably, the script is as in #3 (Jonathan’s solution).

Just choose (set) the reciprocal value under the “custom” entry - like .75 for instance. It works either direction…

Yes, I did that with the Openbox install, but what about the EOS default live iso?

Works the same there - or just use the resolution settings in Welcome for use while live…

1 Like

The resolution settings in Welcome doesn’t change scaling, you can downsize the screen resolution.

Checked the EOS live iso again, and added
xrandr --output eDP1 --scale 0.75x0.75
to Session and Startup and logged out and logged in to check. It worked.
After scaling,

1 Like

You can just use the Settings/Display app, and apply a custom scale factor too… They don’t assume you know xrandr that well!

2 Likes