How to enable the 'super' key?

Windows manager shows keybindings for tiling windows that involve the key super. I would have thought that would be the Windows key, but it’s not. I guess I’d have to do some configuration tweaking for that. Any suggestion?



AFAIK, it is. Give more justification about it. Why do you think it is not?

Check: Create a new keybinding, using Super (Win) key for modifier. What happens?

On 105 key keyboards, there are two “Windows” keys. One on each side of the space bar.

Depending on the software, Both could be active, or only one is active. If only one Windows key is active, it is usually the left one.


The keybindings you show in your Window Manager screenshot work for me. However, I first had to perform the configuration described in this post:

Edit: In newer installations of EndeavourOS, the steps above are no longer necessary. Instead, the Super key is pre-configured to open the popup Applications Menu (same as Alt+F1) and the Super+Arrow (Keypad) combinations tile windows.

Revision (2023-04-06):

I have rewritten my instructions for modifying Super key functionality so that they work with the latest offline installations of EndeavourOS:

Proof the Super key is disabled: because the shown keybindings don’t respond. For example, I do Alt-tab to activate Window Manager as shown. Then, Super+Page-Up. Well, nothing happens. This is a keyboard with only one Windows key.

I did that and Super binds to the menu (two taps). Also Super+E opens Thunar, but that binding is not listed in Windows Manager>Keyboard. OTOH, some bindings are listed that do not work. For instance, Super+ is supposed to tile the active window, but it does not. The keyboard window shown is just before removal of the shown row (xfce...). I did a logout/login after that.

Those shortcuts have been set up on the 10-key. The normal Page Up/ Home / End etc keys will not work, they have to be the secondary ones on the 10-key.

1 Like

Why do these binding show on Window Manager>Keyboard? What are alternative ways I can do windows tiling from the keyboard?

Please see the edit I made to my previous post. I apologize that my post led you astray.

@BluishHumility is correct in the post below. Your keyboard does not have a numeric keypad.


So the pre-configured keybindings for tiling won’t work. You’ll need to remap the tiling actions to keys that do exist on your keyboard.

In the Window Manager, on the Keyboard tab, select the action you want to change and click the Edit button. Then type the new shortcut you want to use. For example, I just tested, and these keybindings work well:

  • Super+I for tile up.
  • Super+K for tile down.
  • Super+J for tile left.
  • Super+L for tile right.

The 10-key is part of the keyboard.

If you don’t have a 10-key, you need to change those keybindings to something else. You can still use Page Up, etc just not the one that says “keypad” next to it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.