How to enable tap to click on touchpad?

It has happened to me on several distros, and I don’t know how to get it to work. I have just installed EndeavourOS, and tap to click on touchpad doesn’t work. I have already installed libinput which seems to be an alternative driver to Synaptics, but it’s not working yet.

Does anyone know how to enable it?

Thanks in advance!

Which DE are you using?

Gnome.

Did you install xf86-input-libinput?

Check the Arch wiki i think you need to add something like this?

https://wiki.archlinux.org/index.php/Libinput#Installation

/etc/X11/xorg.conf.d/30-touchpad.conf

Example:

Section "InputClass"
    Identifier "touchpad"
   	    Driver "libinput"
    MatchIsTouchpad "on"
    Option "tapping" "on"
    Option "AccelProfile" "adaptive"
    Option "TappingButtonMap" "lrm"
EndSection

Edit: This is the button remapping setup example.

Yes, I have added that and after rebooting my system, it’s still not working…

Is the touchpad working at all? Or it isn’t even recognized?

Yes, the touchpad is working, just tap clicking doesn’t work. So, I have to use the “click” button for that.

How are you tapping to “click”

Just like I did on Windows and on other Linux distros where tapping to click works. I just tap on any area of my touchpad and nothing happens.

Let question. Are you using wayland? If so try xorg?

Did you go through the wiki? There is with libinput and or with xorg configuration plus a bunch of other stuff. I’m no expert on this as i am not a laptop user but just picked one up. So i might be joining the club. :grin:

I just did this on my laptop running eos and openbox. FIrst, run xinput list to get the id-number of your touchpad. Then run xinput list-props ID_NUMBER to see the properties of your touchpad. You’ll see tap to click or something to that effect listed, presumably set to 0. Note the property number in parentheses. Then run xinput set-prop ID_NUMBER PROP_NUMBER 1. That should do the trick as a one-off, but the question is how to make it permanent. I just have that line in my openbox/autostart and it works fine, but with gnome I assume you’ll need to put to put it in a script to run at login or some such. There’s probably an easier way, but this worked for me.

worked for me after enabling the setting here

Thanks so much @AnotherPenguin!! :grin: That has worked for me as well!

1 Like

So Gnome has some settings not turned on? Glad it’s working now. :+1: