How to enable built-in laptop webcam

Hi! I have an old laptop that runs EndeavouOS quite perfectly, the only “issue” that i encounter so far is not being able to get the webcam of this machine work. I come here to ask for some help because i don’t know if its only a driver-kernel related situation or if its camera has physical hardware issues.

using the command inxi -FAZ --no-host | eos-sendlog, i got those infomations:

  Kernel: 5.16.4-arch1-1 x86_64 bits: 64 Desktop: GNOME 41.3
    Distro: EndeavourOS
  Type: Laptop System: Digibras product: NH4CU03 v: 1.0
    serial: <superuser required>
  Mobo: Digiboard model: NH4CU03 v: 1.0 serial: <superuser required>
    BIOS: American Megatrends v: 1.00W date: 04/16/2013
  ID-1: BAT0 charge: 15.6 Wh (76.1%) condition: 20.5/23.8 Wh (86.4%)
  Info: dual core model: Intel Core i3-3217U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1036 min/max: 800/1800 cores: 1: 876 2: 1041 3: 1432
    4: 798
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Display: wayland server: X.Org driver: loaded: i915
    note: n/a (using device driver) - try sudo/root resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
    v: 4.2 Mesa 21.3.5
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.16.4-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.44 running: yes
  Device-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce
  IF: wlan0 state: up mac: 24:0a:64:f4:58:be
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp2s0f2 state: down mac: 80:ee:73:bb:c1:10
  Local Storage: total: 327.81 GiB used: 41.18 GiB (12.6%)
  ID-1: /dev/mmcblk0 vendor: SanDisk model: SC32G size: 29.72 GiB
  ID-2: /dev/sda vendor: Hitachi model: HTS725032A9A364 size: 298.09 GiB
  ID-1: / size: 289.29 GiB used: 37.41 GiB (12.9%) fs: btrfs dev: /dev/sda1
  ID-2: /home size: 289.29 GiB used: 37.41 GiB (12.9%) fs: btrfs
    dev: /dev/sda1
  ID-3: /var/log size: 289.29 GiB used: 37.41 GiB (12.9%) fs: btrfs
    dev: /dev/sda1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 6.5 MiB (0.1%)
    dev: /dev/sda2
  System Temperatures: cpu: 55.0 C mobo: 29.8 C
  Fan Speeds (RPM): N/A
  Processes: 249 Uptime: 2h 6m Memory: 5.69 GiB used: 2.42 GiB (42.5%)
  Shell: Bash inxi: 3.3.12

Just some more info for anyone who might be able to help:



sudo dmesg | grep cam

to see if the camera is recognized.

Hopefully this will give some idea to other forummates.

Perhaps cast an eye on this as well:

Welcome to the forum @D_el :partying_face::tada::balloon:

Did you use the camera before installing EOS? If this is a “new” used notebook, the camera might be disabled in BIOS.

lsusb returns this:

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo dmesg | grep cam didn’t returned nothing on the terminal

1 Like

Thanks! :smiley:

Well, yes, i remember this webcam working a long time ago. I dont know if it helps, but this laptop was shipped with windows 8 intended to be the default OS circa 2012-2013.

(I went into the Aptio Setup Utility using F2 on the reboot, but under the security tab i got no info or option about webcam being enabled nor disabled)

I am not seeing anything related to any camera, but let’s see if other forummates could join in here.

I have absolutely no expertise on this matter. I would try to narrow it down by testing the cam in a live system (LinuxMint for example). Boot live system and start Jitsi Meet ( in the browser, open a room and the browser will ask permission to access webcam and mic. If it works you’ll see your face in an instant.

guys, i got the webcam working just fine! it turns out that it was disabled through fn + f7 command, but since the f number keys have all icons almost vanished i never tried pressing some combination before. i tested the cam on gnome cheese and obs studio, i got video without problem at all.

even the command sudo dmesg | grep cam now give me this:

[  124.705594] usb 1-1.1: Found UVC 1.00 device  HD Webcam (04f2:b351)
[  124.726661] input:  HD Webcam:  HD Webcam as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.0/input/input18

Glad that its working (but a bit ashamed because the solution was something that stupid :skull:)

Thank you all for the support anyways, i learned a lot of new stuff!!!

1 Like


It also happened to me once… :rofl:

I didn’t even know there are laptops with toggle key for the camera. I’d like to have one.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.