How to enable autologin in SDDM?


I’m trying to create a script to make the SDDM prompt skip to the kde splashscreen

According to the arch wiki this can be achieved by adding this script under “Autostart”

/usr/bin/dbus-send --session --type=method_call --dest=org.freedesktop.ScreenSaver /ScreenSaver org.freedesktop.ScreenSaver.Lock &

Which is what i did


Here’s the .sh file i had made

I hope arch-related questions are accepted here,

i am not the pro on plasma or sddm but there is a config in the settings to do that or not?

You seem to have misunderstood me,I do not want to disable the splashscreen i merely want sddm to autologin and skip to the splashscreen.

Perhaps this:


You might want changing the title of the topic to better reflect the issue you are trying to resolve:
“How to enable autologin in SDDM?”

Yes could be my magic ball is blurred :wink:

Autologin is working?
So go disable splash to not let it show up in settings.
Autologin is not working?
set it up in settings:

thanks buddy

Guess you didnt misunderstand me after all haha

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.