How to enable apparmor?

I have enabled apparmor.service. I have followed the steps given in archwiki.

Open /etc/default/grub with sudo permissions with nano or vim or vi or what ever is your favorite editor.

Open the terminal

$ export $EDITOR="your favorite editor" 
$ echo $EDITOR                 --> to check that the editor is properly set
$ sudoedit /etc/default/grub   --> it will prompt you for your password write it and hit enter

Now add in the line
GRUB_CMDLINE_LINUX_DEFAULT = " quiet apparmor=1 security=apparmor ..."

Save the file

$ sudo update-grub  --> it will prompt you for your password write it and hit enter

Restart your pc / laptop

:crossed_fingers:

If you followed the steps then it should be enabled and working… :thinking:

Did you also do the thing that immediately followed enabling the service?


Interestingly, this doesn’t follow what the Arch wiki says - why is there a difference here?

I’m almost certain that EnOS doesn’t include this wrapper. Copy-pasting something from another forum isn’t great, and especially so when it’s based on a fundamentally different distribution and so ends up being misleading.

4 Likes

I am getting an error. It says invalid argument.

sorry i thought it should work in eos as not only manjaro but other ubuntu derivatives also follow this command

On Buntu and Manjaro, update-grub either runs a script or is aliased to:

grub-mkconfig -o /boot/grub/grub.cfg

on Arch, btw, as well as on EndeavourOS, this alias does not exist.

Just copy-pasting a solution from another forum for another distro might be dangerous and you could cause more harm than good, if you do not understand what it does.

2 Likes

Some of us have popped in an alias that does the same thing - but it is not a default by any means. Easily fixed by posting the alias beforehand, or the full command in posts…

What does? When? Where?

2 Likes

In terminal while adding apparmor to lsm=.

That doesn’t make much sense - could you expand on exactly what you did?

1 Like

https://wiki.archlinux.org/title/Apparmor#Installation

For adding kernel parameters, choose the instructions for the bootloader you are using:

https://wiki.archlinux.org/title/Kernel_parameter

1 Like

I did this on a machine recently and couldn’t get it to work following the arch wiki.

This is what worked for me:

  1. sudo systemctl enable apparmor.service

  2. sudo nano /etc/default/grub

  3. find the line that starts with:

GRUB_CMDLINE_LINUX_DEFAULT =

add this:

apparmor=1 security=apparmor

  1. Hold ctrl and O

Note: the letter O, not the number zero.

  1. Hold ctrl and and press x

  2. grub-mkconfig -o /boot/grub/grub.cfg

  3. reboot

  4. check if apparmor is running with:

systemctl status apparmor

or

aa-enabled

(deleted by author)

Could you please elaborate the methods. I could not understand what to do? How to determine your bootloader?

If you installed EnOS then you have GRUB.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.