How to enable 4K output on Raspberry Pi 400?

Hi,

I have just installed Endeavour on my Raspberry Pi 400 and all seems to be good apart from i can only select upto 1080 resolution in the display settings (no other resolutions are available in the dialogue). I was hoping to be able to run in 4K (as my monitor is 4K). Is 4K supported in Arch/Endeavour on the Pi 400 ?

BTW, i am using XFCE4 desktop

Thanks on advance for any help/advice.

1 Like

Very nice. Is it easy to install on the Raspberry Pi 400. Do you boot off the usb drive and install it onto the sd card?

I just setup the sd card on my other desktop running Endeavour as per the instructions then booted the Pi 400 and completed the 2nd part of the install … went pretty smoothly … but sadly no 4K :frowning:

1 Like

My question would be:

Apparently yes it is…

Not sure if that is just playback resolution :thinking:

2 Likes

I just hope that’s not just “marketing speak” in that it is capable of playing 4K videos (which is not the same as running a 4K display…).

If it’s supported then there should be a way of configuring it to work - there’s a fair bit of RPi support in the mainline kernel.

Might need to be set in the config.txt : https://www.raspberrypi.org/documentation/configuration/config-txt/video.md -> hdmi_mode.

I just a po’ boy, can’t afford no stinking 4k stuff. :wink:

But seriously folks, take my wife…PLEASE.

My Raspberry Pi 400 supposedly shipped yesterday, expect it next week some time.
So, I have neither a RPi 400 nor a 4k device. But I found this that might shed some light on the subject. This is for a RPi 4b, but should be the same for the RPi 400.


Notice it says “Only one video output supports this mode - microHDMI-0. It is the one located closer to power-supply of Pi 4.”

Anyway looks like some good info there.
HTH

Pudge

3 Likes

The RPi.org site says the Pi 4B should support two 4K displays - so it should be possible with the 400 too. :thinking:

2 Likes

I hope you are correct and the article is wrong.

Pudge

1 Like

HDMI 2.0 is 4K 60 fps certified, so the problem is somewhere else.

I saw a YT review (can’t remember witch one) but he had problems using his 4K display, in respect of making the screen readable, due to resolution. He then explained how to use pixel doubleing. This was using RaspOS, but yeah, evidently Pi400 does support 4K.



But the PI400 lists only this ath their webside:
Processor: Broadcom BCM2711 quad-core Cortex-A72(ARM v8) 64-bit SoC @ 1.8GHz
On reviews disassemble videos they say also the board is different and also the main chip have another number…

3 Likes

I finally received my Raspberry Pi 400 today. I set it up and booted into the included uSD with Raspberry Pi OS (formerly Raspian) and it worked fine with the default LXDE.

However, I cannot install ArchLinux Arm on it as mutley did.
During boot up, it goes looking for files on a server somewhere. Then throws the error:

A quick search yielded the following:

Then the keyboard was unresponsive so I could not poke around any.

Next I inserted the uSD Raspberry Pi OS, disconnected the Ether net cable and disabled WiFi to see if it would boot with out being able to contact a server somewhere. It booted fine.

On a side note, the space bar on the keyboard sticks. About 2 out of 3 times it sticks with a delay then releases. About 1 out of 3 times it sticks and does not release with the cursor heading right on the screen. I have to lift the front of the keyboard slightly then drop it so the jarring releases the spacebar.

Not a happy camper at the moment.

Pudge

2 Likes

Ouch! Sounds like an RMA to me - they should certainly have managed to debug the physical keyboard by now! Keep us updated - the current situation is no time to be fighting with the hardware!

The first couple of failed installs were attempts at installing a 64 bit (aarch64) Archlinux Arm base install.

Since mutley successfully did an install, I was stumped. Not knowing what else to try, out of desperation I tried a 32 bit install. The SOC (system on a chip) is capable of running either 32 bit or 64 bit.

The 32 bit install worked great. I am disappointed that 64 bit doesn’t work at this point. The Raspberry Pi 4b runs 64 bit OK but not the RPi 400. :man_shrugging:

The space bar is starting to get better with use, so we will see.

Pudge

4 Likes

If you have the means to ‘pull’ the spacebar, and take a look at what best lubricates key switches, perhaps it can be cured completely. I won’t specify any particular procedure, but the information is ‘out there’ :grin:

Weird that the 64 bit version won’t work directly (yet) but I suspect that is a temporary situation - only an update away…

2 Likes

I wonder if part of the problem is how an Arch 64 bit install differs from the Raspian 64-bit beta. In both Arch (32-bit and 64-bit) and Raspian 32-bit, all your overlays and drivers are configured in /boot/config.txt. Whereas the Raspbian 64-bit beta, the overlays and drivers are configured in /boot/firmware/usercfg.txt. It is my understanding, that when the firmware of the Raspberry Pi 4 detects a 64-bit OS, it looks for the configuration in /boot/firmware/usercfg.txt first and then it will look /boot/config.txt as a fallback. Even then, it may not implement all the arguments in the /boot/conifg.txt.

For example, Under Arch 64-bit, the Raspberry Pi 4 will not implement any Raspberry Pi 4 specific overlays in the /boot/config.txt. However, if one adds a [pi4] flag in the /boot/config.txt before the overlay configuration, the Raspberry Pi 4 will then apply the setting.

My /boot/config.txt on a Arch 64-bit install.

disable_overscan=1

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
gpu_mem=320

This not only disabled the overscan issue I was having, black bars on the top and bottom of the screen, it also enabled video acceleration. Without the [pi4] argument, video acceleration was not being enabled despite it being in the config.txt.

All that being said, @mutley add the following to your config.txt file:

hdmi_enable_4kp60=1

So for an Arch 64-bit (and 32-bit) install, the config.txt should look similar to this:

disable_overscan=1

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2
gpu_mem=320
hdmi_enable_4kp60=1
3 Likes