How to disable touchpad on hyprland

I am using endeavoros with hyprland and gnome base.
Xinput can’t use because i am using xwayland.
I tried libinput-gestures but it doesn’t run on my system so i try libinput.

My touchpad info from libinput:
Device: PNP0C50:0e 06CB:7E7E Mouse
Kernel: /dev/input/event4
Group: 5
Seat: seat0, default
Capabilities: pointer
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: disabled
Nat.scrolling: disabled
Middle emulation: n/a
Calibration: n/a
Scroll methods: *button
Click methods: none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles: flat *adaptive custom
Rotation: n/a

I used this command:

[ 8:55AM ] [ host@host-modern15a5m:~ ]
$ libinput list-props
libinput: list-props is not installed
[ 8:55AM ] [ host@host-modern15a5m:~ ]
$ libinput list-props “PNP0C50:0e 06CB:7E7E Touchpad”
libinput: list-props is not installed

What should i do now?

welcome to forum…

i no use Hyprland :pray:

take look in your
" .config/hypr/hyprland.conf "

just a guess. :pray:

Edit forgive my english no great … no real sure what try to achieve?
fast web search point here

" https://wiki.archlinux.org/title/libinput " (section 2)

plus links " https://gitlab.com/warningnonpotablewater/libinput-config "

like i said "i no use hyprland or wayland " so it just guess … hope it help little

so use at own risk

EDit… i read your post again , notice “Gnome base”

Summary

if your plan disable "Touchpad "if mouse connected ?

Use at own risk ( i no try commands ) may no work

(gsettings disable Touchpad)

Viewing current settings of Touchpad

gsettings list-recursively org.gnome.desktop.peripherals.touchpad

disable Touchpad

gsettings set org.gnome.desktop.peripherals.touchpad send-events disabled-on-external-mouse

enabled it back

gsettings set org.gnome.desktop.peripherals.touchpad send-events enabled

check current setting

gsettings get org.gnome.desktop.peripherals.touchpad send-events

or maybe use " dconf-editor "

To disable a device such as a touchpad, first get its name with xinput list and then disable it with xinput disable name .

https://wiki.archlinux.org/title/libinput#Disable_device

yeh

I don’t know what to do.

I didn’t see option to disable toucpad in there.

gsettings isn’t involved with hyprland.

you put " Gnome base " as you no explain well . my think was maybe you try use gnome , replace mutter with hyprland .

i no idea if it work .

"https://www.reddit.com/r/hyprland/comments/11kr8bl/hotkey_disable_touchpad/ "

maybe see if hyprland have man page ( hyprctl )

hope you work it out , so i wish you luck

hyprctl keyword "device:elan06fa:00-04f3:31dd-touchpad:enabled" false

Works here, get your device name with:

hyprctl devices
1 Like