How to disable screen lock

So it’s basically what the title says; I want to figure out how to disable screen locking in i3wm. I checked the config, and I could not find anything related to xautolock or i3lock (except the keybinding to lock the screen manually). I tried uninstalling i3lock, but my pacman cannot find the package. So I am at a loss, and I defer to you. How do I change the timeout or disable the screen locking entirely?

you want to remove completly or temporarely disable like cafeine if you watch something ?

to change time out is in ~/.config/i3/config or in .xsession …but i believe the package calles i3lock-colors , just do pacman -Qs i3lock

but i do use the lockscreen but have a caffeine entry on panel to disable it when watching video

I think I would like to remove it completely. I did pacman -Qs i3lock, but that does not return any results. Also, it is not in my i3 config, and I don’t seem to have a .xsession file.

in orginal i3lock is configured also there is a Xset command your system get to black after x time inactivity thats also in your i3/config

Is it really locking or only screen went black?

I searched for “Xset” in my i3/config, but I could not find anything. Is there another term I should be searching for?

It’s really locking. I have to enter my password every time.

There is no screenlock in EndeavourOS i3 config, that locks screen without pressing [mod+L] what will manually lock screen.

Okay, so I fixed it using “xset s off” and “xset -dpms”. Thanks for your input, guys. I really appreciate it.

since there is no xss-lock, normally it should not lock when xset is setting in