How to disable recent files?

I am using Files app from GNOME as my file browser in plasma. In recent files tab it shows the recent activity. How do I disable it??

The gnome-control-center has a “Privacy” section in which you can change the settings for “File History & Trash”

I have it disabled only. While using GNOME recent files is not showing but when I use in plasma I see it

You can disable recent files in plasma in System Settings->Workspace Behavior->Recent Files and setting “Do not remember”

I have set it to do not remember and I also tried clear history, forget everything. Nothing worked :frowning:

Might be because it’s GNOME and it’s angry because you put it in plasma. :smiley: