How to disable idle login screen sleep?

My pc goes to sleep after a few minutes if I don’t login via the desktop manager(gdm). I want to use the pc sometimes just with ssh, I want to start the pc then login with ssh. But it goes to sleep, unless I login via the dm, while i’m logged in with ssh.

I don’t know where to disable automatic sleep on the login screen. I looked on the arch wiki, but can’t figure it out, I checked the systemd configs, but didn’t see anything obvious about login screen sleep. I don’t want to disable sleep completely, just the idle sleep on the gdm.

See here:

Just search for “GDM auto-suspend”.

It’s for GNOME 3.28, which is a rather old version, but it might work. I don’t know, I don’t use GDM.


tyvm, I would have never guessed it’s controlled by gdm…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.