How to Delete an ISO File

Hello, mates.

I have an external HD as a simple storage device and today I was unmessing it when I found a folder called ISOs and there was a fedora iso file there, but I can’t remove it.
I also tried the sudo rm -Rf ./filename, but it persists.

Is there any other way to delete persistent files?

If you wanted to delete the folder and not the filename.iso then use
rm -r DeleteThisFolder/
f=force, so only use that iif your 100% sure of what your doing. It will delete everything if you make a mistake with sudo in front of the command

Do a filesystem check (fsck) on the volume; it sounds like it is not right.

If I can’t delete the file, how can I delete the folder? The output is folder not empty.
Sorry, buddy. I really appreciate your hint, but I already tried this way.

I gotta restart the computer and run thd fsck with a live distro, right?

Can you create a file on the disk and delete it?
Maybe the disk is in read only mode?

Yes, a created one by using a touch command and I was able to delete it as by pressing the del button as by using the rm command: rm test.

What message (specifically) is output when you try to remove the file?

What is the output of lsblk -f (i.e. what filesystem does the partition have)?

What is the output of ls -l $filename and lsattr $filename ?

Thanks @jonathon for answering.

The output:


And the filesystem:


But I think that the filesystem is not the problem because I can delete other type of files. Except that damned ISO file.

That wasn’t what I asked for, but good try nonetheless.

1 Like

Haven’t you asked about the output of the command: sudo rm -Rf ./filename? And what filesystem of the partition?

Problem solved.

I used the Windows to delete the damned iso file and it simply did.

Sage people use to say: “if you don’t have a dog to hunt, use the cat”.

I guess you had to open a Window to throw it out! :laughing:

2 Likes

:wink: No doubt.

Nope, usually just an unmount.
So given the screenshots, that the external is NTFS, this is something that I have run across before, and something that occurs because of the fact that the NTFS specifications still have some Mickeysoft proprietary magic in them, making some functions hit and miss. Try running a fsck on a failed boot NTFS partition from Linux; it cannot, only MS’s craptastic OSes can do so.
So I guess the ISO was put onto the disk under windows?
Glad you got it sorted.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.