How to deal with instructions when only Ubuntu instructions are available

Sorry if this has been asked before, I tried searching the forums but couldn’t find an answer.

So I’m new to Linux as a whole. I have EndeavourOS set up and I’ve already overcome several struggles, with quite rewarding results.

My current struggle is that whenever I search for certain apps, the instructions often do not include Arch Linux. Ubuntu is always at the top of the list, and sometimes the ONLY instructions available are for Ubuntu.

Such is the case of an app named ScreenRec which only has instructions on how to install on Ubuntu:

sudo wget -q -O - | sudo apt-key add -

sudo add-apt-repository 'deb stable main'

sudo apt update

sudo apt install screenrec

I tried searching with sudo yay -Ss screenrec, but the app I’m looking for is nowhere to be seen.

I also tried installing dpkg and apt using yay (both succeeded), but I am unable to add the aforementioned app’s repository so that I can use sudo apt install.

I hope that wasn’t too confusing. I appreciate any suggestions!

WHen you google “screenrec Arch” or “screenrec EndeavourOS” you see an ArchWiki page about screen recording options for Arch (which in this case also applies to Endeavour).

You won’t find ScreenRec specifically but you’ll find alternatives.

Unfortunately, Ubuntu instructions generally only apply to Ubuntu. And that particular application doesn’t seem to exist as an Arch package.


I went to their site and you click to be taken to the page that provides the downloads and it only attempts to download the Windows version. Depending on your needs I’d suggest SimpleScreenRecorder instead.

Thanks. That’s exactly what I noticed, which is why I’m trying to learn if there is a way to install an app on Arch if only Ubuntu instructions are available. It happens with several apps.

As for the screenshot program, I’m looking for a way to capture screenshots by selecting the screen area and then annotate on them with lines, arrows, rectangles, highlighting, blurring, etc.

From what I can tell, SimpleScreenRecorder is only for video, or at least I didn’t see the option to just take screenshots.

Thanks for the input!

Generally speaking, you should first check the repos and AUR no matter what instructions you find. Most applications are in one of those two locations. If you can’t find it in one of those places, feel free to ask.


flameshot works well on X11, spectacle works well on Plasma.

1 Like

Welcome @MrJoeCastellon I use spectacle on plasma & it has the features you seem to be looking for.

1 Like

Yeah, I checked all around. Came here as a last resort.
Thanks for the support :slight_smile:


I see Spectacle came installed in this version of Endeavour (either that or I don’t recall installing it :laughing:) but it won’t take a screenshot. I imagine it has something to do with Wayland.

You could see if this is the case by logging into KDE with xorg - unless you need Wayland for something

there is always a snap package of screenrec :rofl:

I don’t have the option to choose KDE with Xorg, but I did try it on Gnome with Xorg and it worked. I wouldn’t know if I need Wayland over X11. All I know according to what I read somewhere is that it’s apparently more secure than X11. I don’t remember choosing Wayland during the setup, so to me it’s kind of like it’s there because it was already set with Wayland by default. Or at least it seems that way to me.

I attempted Cinnamon but many of the shortcuts were different and I’m already used to the ones in Wayland :laughing:

I feel like Captain America in that I don’t understand that reference :stuck_out_tongue_winking_eye:

Just that basically no one uses snaps even though Ubuntu has decided it’s the hill they are willing to die on so they basically only use them and promote them as the answer to the future.

I will never use them at this rate.

thanks for filling me in on that :rofl:

1 Like

This is why EndeavourOS has a wiki. You should be able to find this information quite easily.

I ended up settling for Flameshot on X11. I switched the DE to Cinnamon from Gnome Wayland. I was reluctant because I had already spent so much time customizing shortcuts and what not, but I don’t regret the switch.

Flameshot works exactly as I want it to now. Thanks for the suggestion!

Wouldn’t GNOME on Xorg cut it for you?
I mean, instead of switching to another DE.

1 Like

One of the more striking differences between windoze and Linux is that when we want to install a program, we typically don’t use a browser to find some website from which to download the installer. Most of the software we might want to use has already been packaged for us by the distro maintainers, or the community – so almost always (unless you’re dealing with something really rare, or obtained in a shady way) installing new software comes down to using your package manager. This is, pretty much, the only situation where the concept of Linux distribution is really important, because this determines the available software. Since EndeavourOS is just nicely presented Arch, we get our software from the Arch repos and the AUR.

Most of these “instructions”, even when written by the developers of the software, are not only utterly useless, but also contain really bad practices, like using wget with sudo.

Unless you really have a good reason to use it, I would advise you to stick to xorg. Especially given that you’re newbie. And especially since you want to use SimpleScreenRecorder and Spectacle – your life will be much easier with xorg.

Using a package manager designed for another distribution is a really bad idea, one that is quite likely to render your current operating system unusable.

In fact, even using specific third-party package managers like pip, npm and gem tends to be a bad idea on Arch.


If you use an arch based distro like eos it will be good to familiarize yourself with pacman and the AUR. I also suggest to read and follow links from the eos welcome screen.