How to clean up GRUB menu?

Hello,
right now my GRUB menu looks like this:

and I want it to look as clean as this one again: https://discovery.endeavouros.com/installation/grub-dual-booting/2021/07/

I have three entries that start EndeavourOS and I don"t know how to get rid of two of them.

running sudo grub-mkconfig -o /boot/grub/grub.cfg does not change anything.

/etc/default/grub/ looks like this:

# GRUB boot loader configuration

GRUB_DEFAULT="0"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="EndeavourOS"
GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 nowatchdog"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK="y"

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE="menu"

# Uncomment to use basic console
GRUB_TERMINAL_INPUT="console"

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="auto"

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX="keep"

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY="true"

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/boot/grub/themes/EndeavourOS/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT="true"

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU="y"
GRUB_DISABLE_SUBMENU="y"

GRUB_DISABLE_OS_PROBER=false

Can anyone please assist me and help me to clean up my GRUB menu again?

These are all your installed kernels… you can change the boot order or create a submenu so that it only displays one entry for linux in the main menu.

https://wiki.archlinux.org/title/GRUB/Tips_and_tricks#Multiple_entries

You may be also able to turn on kernel number/version else it is difficult to recognize multiple entries.

2 Likes

The easiest could be to try the grub-customizer Which is a gui that helps you changing does entries

“Fixed(?)” (I don’t know if you can call this a proper fix):

I remembered that I also had Grub-Customizer installed at one point and I followed this post:

su
rm -rf /etc/default/grub
rm -rf /etc/grub.d
exit
sudo pacman -S grub

and then I added GRUB_THEME="/boot/grub/themes/EndeavourOS/theme.txt" to /etc/default/grub/

Thank you for your help. I managed to fix(?) my problem and I think grub-customizer caused my issues in the first place.

1 Like

This is by far not the first time I come across such an statement.

Mmh, isnt that close to “delete all my system” without warning prompts type of command, careful!? :sweat_smile:The -f option forces that…

My understanding is that 1) you removed grub customizer (additional command missing?), 2) removed your old grub config files that may have been messed up somehow, 3) installed the grub config file with eos theming. If you got all entries you like then yes you fixed your problem!

Perhaps it could be easier to try to understand next time what was wrong in the config file. One option could be to back it up and compare with the new config file to see what is different and learn from it.

Edit: I recently discovered a neat program to do this visually, its called “Meld”

Thank you I will have a look at “Meld” and you are completly right - randomly copy and pasting commands was very stupid. I had already removed grub-customizer a while ago.

Know I am aware that what I was looking for was probably in /etc/grub.d

Well I leave my post up for others to learn from my mistakes :slight_smile:.

1 Like

This is a common mistake that gets many users into some grub issues after having used Grub Customizer.

That is un-installing Grub Customizer without having first used its in-build restore function to restore Grub to a pre-grub-customizer state.

3 Likes

The easiest way to clean up grub is to use rEFInd instead.

(Sorry this is off-topic, but I simply could not resist)

2 Likes

If you feel the topic is solved please mark the appropriate post. :hugs: Click the three dots and check the box.