How to change from DHCP to Static Headless

Good day, I’m knew to EndeavourOS ( well to Arch all together ) and I can’t seem to change the system from DHCP to static no matter what I try.
thanks

Troy.

What have you tried?

Thanks for the reply…

netctl method but sudo netctl start ens33 fails says that ens33 is already in use.
and I looked to see if /etc/systemd/network/ was setup. Not sure where DHCP config is coming from I disabled and removed DHCPD and DHCP-client.

Are you using Network Manager by any chance?

Your DE will have a network settings area which will let you set a static IP address, e.g.

no it’s headless. I don’t have gui…
I also look for /etc/netplan/ ( Ubuntu way ) and /etc/sysconfig/network-scripts/ ( centos way.)

oh but you just helped… nmcli is where this is configured.

Also nmtui can be quite handy.

Ok so i am having the same issue and while I now know my issue is in nmcli, what did you do to resolve it? Can i just delete the config from nmcli??

You could move it for backup first and delete it after successfull new configuration.

sudo mv /path/to/configfile/filename /path/to/configfile/filename.backup

better open a new post… 10 months later on a rolling release will not be the same :wink:
– closing –

2 Likes