How to boot directly to the OS selection screen?

I am on a Dell laptop with 2 SSDs. One SSD has Windows 11 and another has EndeavourOS. Can you please tell me how I can set things up so that it directly takes me to the OS selection screen? Right now I have to frantically push the f12 key, then select the right option and if it is EOS, I have to again select another option. I am attaching the selection screen for reference.

Thanks for the help!

Hi. Welcome to the forum! :enos:

If your BIOS has settings to change default boot option, you can use that to switch default to EndeavourOS. (HDD3 in your case I believe). Otherwise, you can use efibootmgr to change boot order / options from your EndeavourOS system.

Which other option? What menu do you get?

Thanks for the quick reply. I’ll try to do both of those things. I don’t want to make EOS the default, I want to choose every single time.

I get an option to select between: EOS, EOS(default), Win11 and BIOS settings.

1 Like

Which bootloader did you select during installation? If it was Grub or Refind, it should give you a menu to choose between Endeavour and Windows. (If using Grub, you may need to manually enable os-prober)

grub and systemd-boot it is :wink:

1 Like

As @joekamprad said, I used systemd. This is my first time really trying to learn Linux so I chose the defaults wherever I was unsure.

So you want to stay on boot on the bootmenu and be able to choose what you want to boot wihout it going to boot any after a period of seconds?


Yes, I want to come to this screen by default and remove the timer. Also, earlier whenever I tried to boot into Win11 from this screen, it kept rebooting the system. Not sure what that was and I haven’t tried to boot into Win from this screen since. If there’s any more info I can/should be giving, please let me know :slight_smile:

could be the windows bootloader changed, and you need to recopy the files over (in case you have different esp partitions in use)

I do not think you can disable the timer-- setting it to 0 will disable the menu and go to boot the default set entry directly you can set timeout to something like 99999999999 maybe :wink:


Thanks, so I think I’ll need to figure out how to change the default boot option (the bios settings are quite weird on this Dell laptop). And then I’ll figure out how to change the boot timer, and lastly figure out what’s the issue with the Windows bootloader. Thanks a lot!

boot timer is only a line in the config:

for the windows boot issue you can share your drive/partition scheme:

lsblk -f

Here it is:

As I was thinking… EndeavourOS is on its own drive and with its own ESP.
To add the Windows boot entry installer is copy over the /EFI/Microsoft from the windows ESP to the Linux bootloader folder… could be in case it has changed caused by a Windows update or changes you have done under windows.

1 Like


In this one the ESP from Windows you will have a folder named Microsoft

this one needs to get copied to /efi/EFI/Microsoft on your EndeavourOS drive:


i mean replacing the one that should be there already from install process.

1 Like

Alright. And quick question, if I delete a boot option from one of these in the screenshot attached, do I lose it like permanently?

The entry in your nvram yes but thats not the bootloader itself you can always rewrite them to the nvram using bootctl…

sudo bootctl install --efi-boot-option-description="EndeavoaurOS" (adding --efi-boot-option-description= will use the phrase you add there instead of the default “Linux Boot Manager”)
For EndeavourOS / Linux

Also from a running Linux or LiveISO you can manage the entries using efibootmgr tool.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.