How to Add gnome-search-tool to XFCE4 Thunar

Thunar is a great low resource file manager. However, for me the lack of a search feature
is really aggravating. Here is how to add gnome-search-tool to Thunar and it only costs you 50 MiB

As root install gnome-search-tool
# pacman -S gnome-search-tool (Total Installed size: 49.93 MiB)

Open Thunar
Click on “Edit”
Click on “Configure custom actions”
Click on + to add a custom action
Under the “Basic” tab fill in
Name: Search for files
Command: gnome-search-tool --path=%f --contains=
Click on the box next to Icon: then select the “system-search” icon and click OK
Click on the “Appearance Conditions” Tab
In “Appears if selection contains:”
Enable “Directories” “Audio Files” “Image Files” “Text Files” and “Video Files”
Click on OK
Close “Custom Actions” window

In Thunar, select a directory or device, (For illustrative reasons highlight “File System”)
Right click, then click on “Search for files”

OR

Since I believe in full transparency, and giving credit where credit is due.
Go to this site for further details

Pudge

4 Likes

good to bring this up, as Thunar have some nice features user are not aware of :wink:

i do not like tracker (used by gnome-search) as it is causing huge systemload on tracking for files and the db is growing fast in size…

But you can use almost any app or command you want inside this setting:


i add catfish what is now part of XFCE itself:
https://launchpad.net/catfish-search

4 Likes

To make catfish work you have also look the optional depency otherwise no sezrch :sweat_smile::sweat_smile::sweat_smile::sweat_smile::sweat_smile:

I use KDE and dolphin now, but when I used Xfce I really liked the customization that Thunar permitted. I added actions for search, encrypt, decrypt.

Thunar stores Custom Actions in: ~/.config/Thunar/uca.xml
You may edit that file if you want to. At the very least make a backup of your hard work. And if you ever have to reinstall just copy the backup to your new installation.

yeah with thunar you can do costumze things :slight_smile:

1 Like

mlocate is installed per default on EnOS :stuck_out_tongue_winking_eye:

2 Likes

@Pudge!

Thank you, this worked for me.
I’m a complete newbie and everything was exactly as you said, except for one tiny detail:

#pacman -S gnome-search-tool did nothing when I typed it into the terminal.

sudo pacman -S gnome-search-tool worked however.

“Why is that?” Focus asked, purely out of curiosity.

Based on that statement, I am going into great detail as a learning experience. Non-newbies please bear with me.

There are two types of users in Unix/Linux:
‘root’ Every Linux installation has by default a root user. By default the root user’s home directory is /root This is carved in stone and It is not possible to change either of these. The root user has an extensive set of commands that are not available to the regular users. These extra commands are usually system commands (such as pacman), which are used to define and configure the Linux Operating System. If you have root privileges you can do anything you want to the system, including bad things either by accident or by design. On a commercial Linux system, only a few System Administrators have full root privileges.

‘user’ A user is just that, they just use the system and do not administer or change system parameters. So users have a lot fewer commands that they can use, ideally just enough to do their job.

When a terminal window (or Console window) is used for CLI (Command Language Interface) commands, by convention a $ indicates a user prompt and a # indicates a root prompt. So if a $ is shown as part of the prompt, the user has a limited set of commands he can execute. If a # is shown as part of the prompt, then they have the full set of commands available to them.

In the Original Post the author made a typo in the pacman command. It was

Install gnome-search-tool
#pacman -S gnome-search-tool (Total Installed size: 49.93 MiB)

It should have been with an explanation to use root, and a space between # and p

As root, Install gnome-search-tool
# pacman -S gnome-search-tool (Total Installed size: 49.93 MiB)

The first line of your screen shot shows a $ indicating user mode followed by my line with the syntax error.
$ #pacman -S gnome-search-tool
It failed for two reasons, the command was issued as a user, and the command had a syntax error, namely the #pacman.

The second time you issued the command, you had the correct syntax and issued the command with sudo which gives temporary and sometimes limited root privileges to that user.

The other thing you could have done is
$ su ( su = switch user. when no parameter is given it assumes root )
root password
# pacman -S gnome-search-tool

That would have run the command with full root privileges.

Thanks for pointing out my error in the OP, I will fix it immediately.

Pudge

2 Likes

Thanks for your explanation @Pudge, I learned a lot from it

1 Like