How the xfce4-terminal drop down font menu is populated

I am trying to figure out why the drop don font menu has holes in it (showing empty line with no font assignment) - I do not know how the menu is populated.

Thank you

welcome here at the purple side :milky_way:
And lets go to solve your issue :wink:
I am not sure if i understand your question… “drop down fontmenu” means the font menu in xfce4 drop down terminal? or the font chooser in xfce4-terminal settings in general?

Yes - the picture is correct.
I am looking for the process / populated font file which is visible in the drop down menu.

Can you share a screenshot of what you are seeing? I am not sure I understand the issue.

I think they want to know what font the xfce4-terminal in drop down mode uses and how to change it.

or want to know where the font files are located?
font files are saved under /ur/share/fonts and there in subfolders for TTF OTF and others.

/usr/share/fonts/
├── otf
│   └── SourceCodeVariable
│       ├── SourceCodeVariable-Italic.otf
│       └── SourceCodeVariable-Roman.otf
└── ttf
    ├── AnonymousPro
    │   ├── Anonymous-Pro-B.ttf
    │   ├── Anonymous-Pro-I.ttf
    │   └── Anonymous-Pro.ttf
    └── CascadiaCode
        ├── CascadiaCode-Bold.ttf
        ├── CascadiaCode-Light.ttf
        └── CascadiaCode-Regular.ttf

In addition to this systemwide font folder you can have fonts also under your users home directory:
~/.local/share/fonts/
What you could use to easily copy font files there and have them available for this particular user only.
after adding fonts to any of these directories you need to update fonts cache by running fc-cache from terminal.
see here for more information:
https://wiki.archlinux.org/title/Fonts

And indeed you can also install fonts from repositories or the AUR.
pacman -Ss font
pacman -Ss TTF
or on AUR by using yay yay -Ss font e.t.c.

Sorry - I was misunderstood.

  1. I know font location, how to add and remove fonts both user and system
    I am able to see the new fonts or do not see the removed / disabled fonts.

My problem - the drop down font menu has “holes” in it (lines with no entries / showing blank) . I can scroll up/down further until I will find valid entries.

I need to know how to fix it. This is not an urgent issue.

As an work around I’ve installed Konsole - superior to Xfce4 terminal and works as expected.

aha never saw such happens… could you share a screenshot?
Could be related to the theme in use ?

Welcome to :enos: forums.

What is that theme and what your DE/WM?

x11

OS: EndeavourOS Linux x86_64          
              `:+sssssssssso/.            Host: Precision M6600 01              
            `-/ossssssssssssso/.          Kernel: 5.10.90-1-lts                 
          `-/+sssssssssssssssso+:`        Uptime: 14 hours, 47 mins             
        `-:/+sssssssssssssssssso+/.       Packages: 1064 (pacman)               
      `.://osssssssssssssssssssso++-      Shell: bash 5.1.12                    
     .://+ssssssssssssssssssssssso++:     Resolution: 1600x900                  
   .:///ossssssssssssssssssssssssso++:    DE: Plasma 5.23.5                     
 `:////ssssssssssssssssssssssssssso+++.   WM: KWin                              
`-////+ssssssssssssssssssssssssssso++++-   Theme: Breeze Light [Plasma], Breeze  
`..-+oosssssssssssssssssssssssso+++++/`   Icons: [Plasma], Fluent [GTK2/3]

EDIT: Added code tags.

Have you tried changing you gtk theme to breeze to see if the result is the same or different?