How do I uninstall wayland or at the very least default boot to x11?

For my current hardware configuration wayland is complete and total trash.

How do I remove it so I can only have x11?

If I can not do that then how do I default boot to x11?

I dont want to log off and then log back in to flip it constantly.

If you are using sddm as the display manager, selecting X11 once will default to that selection subsequently, until you select Wayland and then the default changes. The selection sets the default.

Log out, select X11 desktop session on the bottom left of the SDDM login screen.

Every time I reboot my pc it defaults back to wayland.

I do not have a reason to ever use wayland other then to raise my blood pressure.

Thanks for the screenshots but that is what I have been doing for months now.

I don’t want to constantly do that every time I reboot.

When you change it to Plasma (X11), it should stay that way. It should become the default option as @eznix said above.

Since sddm remembers the last choice made under a pure Arch Linux install, and other EndeavourOS users expect the same behavior, I wonder what might have changed in your setup to alter that behavior.

That’s strange, my settings always save when I switch to X11 or Wayland in gnome and KDE

What problems is Wayland causing? You can try XFCE, it’s only X11 for now. Although it will offer Wayland during the next major version

It has been slowly getting better recently but I still have issues with the following.

  • Constant screen flickers when playing videos or games.
  • When typing letters disappear and then reappear after a few secs
  • Windows at times act weird be either losing the task bar around it or becoming semi transparent with background images being saved to the window.
  • Clicking on things are hit or miss, sometimes its higher or lower then the actual thing I am trying to click on.

I actually considered going back to windows because of how annoying it is.

Maybe ill download XFCE and try that out.

It only remembers the last session if you login interactively using the DM. If you have autologin set, you need to modify the config file.

Edit the file /etc/sddm.conf change to Session=plasmax11 and after reboot it should start X11 session again.

2 Likes

Since I have never used autologin, I did not know this. Thanks. :slight_smile:

oddly enough that file is empty for me.

I am guessing it should be filled with something?

Which DE are you using?

KDE

image

See if the file is in /etc/sddm.conf.d

Where do I add it?

image

You modify the line that starts with Session=

I just rebooted and it started on x11.

Thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.