How do I stop using wayland?

Hi all,

I’ve been reading up on this but can’t seem to get it to work. I use Gnome and GDM. Based on what I’ve read, I should be able to see a gear icon at the login screen to switch between Xorg and Wayliand, but I do not have that on my log in screen.

While reading up on this, people suggested that I am already using Xorg, but the about page in Gnome settings says Wayland and also:

[user@labrat ~]$ echo $XDG_SESSION_TYPE
wayland

I also read I can force GDM via configuration:

[user@labrat ~]$ cat /etc/gdm/custom.conf 
# GDM configuration storage

[daemon]
AutomaticLogin=user
AutomaticLoginEnable=True
# Uncomment the line below to force the login screen to use Xorg
WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

Finally, I checked to make sure I have a video driver for my display and I have:

[user@labrat ~]$ pacman -Qq | grep -i xf86-video
xf86-video-fbdev
xf86-video-vesa
xf86-video-vmware

I am using Virtualbox with guest additions installed so I think the VESA driver above should be appropriate for it?

Any ideas what I am missing?

Thank you!

in gdm you cant select xorg session?

I can’t find anything in GDM that will allow me to pick. I just see my name at the center of the screen and when I click on it the area switches from displaying my name to displaying a password input box (which has an eye on the right to allow you to see the password as you type it).

On the top right I see the gnome options for accessibility and turning off the system.

Rebooting has gotten me into X11, but sadly, I still don’t see an option to switch between the two…

you see a wheel some where right under the login ?

you can select sessions

This is what I see after I click on my name. There is no wheel/cog. I understand why you’re asking, as this is what I read online, but really I can’t see it on my system!

One thing I have found out: editing /etc/gdm/custom.conf and changing WaylandEnabled to true/false and then rebooting (as opposed to logging out) allows be to switch between Wayland/X11

I just don’t understand why I can’t switch form the login screen, but choosing a setting next to my name as claimed by numerous online resources…

Have you tried entering your password and not pressing “enter”?

@dalto So, nothing new appears as I type my password. I looked around and all I could do is press the “eye” on the right of the input box to reveal my password…

So I switched to SDDM to see if that works and I can pick the session using the dropdown on the top left. This works by simply logging out and back in.

This is what I was expecting from GDM, but it seems like there is some problem with my GDM configuration?

Hi,

When you look at the content in your “/etc/gdm/custom.conf” does it look like this:

# GDM configuration storage

[daemon]
AutomaticLoginEnable=False
# Uncomment the line below to force the login screen to use Xorg
#WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

Also to confirm did you uncommented “WaylandEnable=false”? I remember having allot joy (not) when I used a Thinkpad t450s with an Intel\Nvidia graphics card combo. The issue you found is very interesting.

So, initially I had auto-login enabled. I then uncommented the WaylandEnabled=false line. At that point I found out that by rebooting after editing for “WaylandEnabled=false” or “WaylandEnabled=true”, GDM would switch between X11/Wayland as per this line. But I still could not see anything to “choose” between the two when I logged out. I then disabled auto-login but it made no difference. Finally I switched to SDDM which worked as expected.

I now commented the line “WaylandEnabled=false” to restore the original state with no auto-login. The file looks exactly as you pasted above at this stage, but GDM will always log into Wayland now (i.e. it works like when I have WaylandEnabled=true). If I uncomment the line and REBOOT (not log out and back in) it will switch to X11. But at this stage I’ve left it exactly as you have shown above.

Normally when you click in the password box and go to enter your password the gear icon shows up bottom right.

Thanks all for the suggestions. Unfortunately when I press on my name all that happens is that I can type my password. There is no gear icon visible as per my screenshot above…

I think I will just use SDDM for now.

The last test I did was to flick the “3D acceleration” feature on/off in Virtualbox to see if it will make a difference, but it did not…

I think @kagetora13 above was right. After resetting custom.conf to the state above, I was still not getting the gear when typing the password. However I do now.

I think what happened was as follows:

  • Once I had WaylandEnabled=false or WaylandEnabled=true, the gear would never appear, GDM would just do one of the two without showing the gear.
  • After removing it I tried by logging out and back in, but still could not see the gear.
  • After restarting, I could see the gear again.

So I think my mistake was that I needed to reboot in order to see the effects of these changes.

Now, I still do not understand though why originally (before touching custom.conf) I was not getting the gear to begin with. The only different thing then was that I had auto-login enabled. But now that I get the bottom-right gear, I’ve re-enabled auto-login and it works (as in, I boot straight into the desktop, but when I log out I get the gear on the bottom-right while typing the password).

I can only assume that I did not notice the gear originally?

Anyway, thank you all, but it may have never been an issue, but rather a careless user…

I would not worry too much (I don’t think it was careless). You like the rest of us read documentation and then try to make things as we wish. But then either a misinterpretation or maybe the way it was designed may have caused a conflict (In QA land, where I am from, well we called that a bug). Wait for it Wait for it … is that developers going to break my door down :).

To be honest when I read your thread it is a point of learn for me. I have not used auto logon (too paranoid about security or my wife seeing my web browsing history (LOL) … oh so many KDE websites.

So I would just enjoy your experience as you learn and get your feet wet. Dalto and Rick are use to seeing my post and see how nice they are in helping everybody. Happy Saturday!

It almost looks like the resolution is off on your login screen and it is cutting off the lower portion of the screen. This would explain why the gear may not be showing up.

1 Like

That’s what i thought too.

1 Like