How do i set kwin x11 back

Ok i did something dumb this time, i enabled “Composite-manager” on cairo dock and it changed the compositor, i believe it’s using xfce compositor now, how do i enable and set kwin as my default compositor back ?

I already tried restarting but it did not help
Apparently i do have compositing working but the WM has been changed

┌─<ramon @ ramon-m61pmes2p in ~>
└─<>──» inxi -Ga                                                                         0 < 19:26:01
Graphics:
  Device-1: NVIDIA GT218 [GeForce 210] vendor: ZOTAC driver: nvidia
    v: 340.108 alternate: nouveau non-free: 340.xx
    status: legacy (EOL, try --gpu) arch: Tesla process: 40-80nm
    built: 2006-13 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 02:00.0
    chip-ID: 10de:0a65 class-ID: 0300
  Device-2: Microsoft LifeCam Cinema type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-2:3 chip-ID: 045e:075d
    class-ID: 0102
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver:
    X: loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 92 s-size: 442x251mm (17.40x9.88")
    s-diag: 508mm (20.01")
  Monitor-1: VGA-0 res: 1600x900 hz: 60 dpi: 92
    size: 443x249mm (17.44x9.8") diag: 508mm (20.01") modes: N/A
  OpenGL: renderer: GeForce 210/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108
    direct render: Yes
┌─<ramon @ ramon-m61pmes2p in ~>
└─<>──»     

Post

inxi -Saz

I got kwin x11 running back, after a system freeze while watching a youtube video i believe fsck cleaned the cache and restored kwin back, i’m not really sure what happened but what i know is that i got kwin running back, i tried restarting several times but for some reason the system freeze seems to have helped

So the solution seems to be watching YT videos, or freeze PC with nitrogen :rofl: .

Anyway, looking in journal logs would be the 1st advice for finding clues about the issue.
Have fun!