How do I remove window transparency introduced by EOS theme?

I installed the worm community edition. The installation came with EOS theme but I am finding the transparent menus harder to read.

Is there a way I can turn of the transparency? Changing theme using xlappearance did not remove transparency in windows and menus. (at least in thunar).

If you’re on XFCE D.E. maybe disable the compositor?

System Settings → Window Manager Tweaks → Disable check first option “Enable display compositing”

Otherwise there should be two options at the bottom of that dialogue, just set both of them to maximum (Opaque).

First kill picom (killall -9 picom) then you can just uninstall it with sudo pacman -R picom. Picom is what provides transparency, if you don’t want it you can just remove it.

Or if you want use the other features of the compositor, such as vsync, you can edit the picom config file to remove the transparency or set it only for specific window types/classes/names. It’s a pretty easy to understand config file ~/.config/picom/picom.conf

Endeavouros Worm came with some LXDE but not XFCE. Configuring picom worked for me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.