How do I remove corrupt / invalid packages

Ok, so I go to start my update using Sudo pacman -Syu and it pulls everything I need to update, then it checks my keys and package integrety but then I get aload of errors saying several packages are Invalid / Corrupt, same also happens if I update through the welcome screen.

I hit Y on a few but heres a pic from my phone (hitting Y does nothing anyway as it cancels to update due to an error).
image
Sorry the image is terrible quality…

Any advice, Im a noob when it comes to Linux but am trying to learn.

Hello @Cynocles !! Welcome to :enos: forums!!
:enos_flag:

Please use the forum search function next time!!

1 Like

I had that with a laptop that I did not update for a month or more. Could that be the case?

If so, this helped me

Don’t forget to sudo grub-install after the update worked but before rebooting to avoid the recent grub problem. Assuming you did not update for a while… Else you are going to be stuck in an unbootable system.

A you beat me by a sec!

1 Like

I’m getting faster with experience. It’s the same common issues every single time. If you’re active in the forums long enough, you know the common solutions. That’s how I mostly help here on the forums. I am not yet knowledgeable about most issues as I simply don’t have them in ARM.

1 Like

It’s pretty much how I solved that problem on my laptop, simply searched the forum. Now I take it is important to learn more about keyrings and PGP, and why this occured on my system. That’s why I like arch, you can lean a lot fast.

I missed this and now I fudged up :frowning:

The keyring or the grub install?

The Grub issue :confused:

Im a noob and iv no clue what im doing… Ahh well dead laptop back to windows.

It is difficult to help without more information. But if you are entirely new to Linux you might be better off trying pop OS or Linux Mint. EOS is easy to install but arch based systems require knowledge or willingness to learn about package maintainance ideally. Seing that one problem leads you to hop back to windows, see you back later perhaps…

I suspect you either used an older iso, installed offline and updated, or installed eos on this computer a while back and have not been updating regularly. Arch is rolling release and requires more regular updates than other point release distro a like Pop OS.

For the grub issue, you just had to add the one command I posted above. It is a one time thing, and unlucky if it happened to you.

If you are stuck at reboot black screen…An easier option if you have your data backed up, is to download the latest iso and reinstall eos. Or seek support in the grub thread. People are really willing to help.

https://forum.endeavouros.com/t/grub-2-2-06-r322-gd9b4638c5-1-wont-boot-and-goes-straight-to-the-bios-after-update/30653/1175

1 Like

ITS ALIVE
image

Saved it, hardest part was finding a USB to mount the ISO too xD

2 Likes

Always keep at a USB with Live ISO for emergency purposes!!

2 Likes

Makes one feel good! In general nothing is that broken that it can’t be fixed. Welcome to the purple side :rocketa_purple: of the force.

1 Like

My drive names are long AF aswell I discovered nvme0n1p1 or some shizz lol

1 Like

Yup, I feel you :fist_left:t4:

yup yup yup :fist_right:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.