How do I reinstall EndeavourOS with both root and home partitions being encrypted?

image

So I installed EndeavourOS and configured both sda2 (as root partition) and sda3 (as home partition) to use encryption with the exact same password.

I have tried to mount sda2 as / and sda3 as /home without reformatting but it has failed the installation.

I tried the reformat option:

image

But why doesn’t it ask me to set my password, I am kinda confused what is going on.

Edit: If I format the luks partition (by deleting it and inserting the exact same password) I would get error messages after a long installation about sda3 (the home partition) regardless if I opened the luks container or not (through gparted)

image

1 Like

Yes I am the guy who posted that post on that forum page. BEcause both distros are having the same issue.

It is part of the good style to communicate this to the other forums, you should know this where you are already so long with it.

1 Like

Sorry I don’t quite get what you mean.

Asking the same question several times in different forums is a waste of resources.
Also unfair, since none of the helpers knows about the others.

3 Likes

Old post(s), but should still work; at least get you started:

Refer to ArchWiki for further information.

2 Likes