How do I make the Grub menu the main boot manager

Whenever i restart my pc, or boot into my pc even, it takes me straight to Windows 10, I use a .bat file to restart into the Windows repair options to pick Endeavour, is there any way to make Grub the main boot manager?

Try going into your UEFI/BIOS settings and see if you can put EnOS at the top of Boot priority.

1 Like

Yeah, about that, I found a tutorial, but I cant find the setting anywhere, but there is the boot order for usb, cd, endeavour, and windows, but no grub boot manager to put it in the order, or does it have a different name? I’ll have a look again

Here is the boot priority order:

  1. Windows Boot Manager
  2. USB HDD:
  3. USB FDD:
  4. HDD: TOSHIBA MQ01ABF050 (EndeavourOS)
  5. ATAPI CDROM: HL-DT-ST DVDRAM GUE1N
  6. Network Boot-IPV4
  7. USB CDROM:
  8. Network Boot-IPV6
    (I also tried putting EndeavourOS above the Windows Boot Manager, but it just took me to EndeavourOS, and not Grub)

I used to use this simple tool to recover Grub after installing Windows, for example, or possibly after installing another distribution.

By the way, there is a description of this on the EndeavourOS page.

Ah, I’ll give it a shot, thanks

I have a UEFI system, but what are the following settings like they mentioned here:
“Before you are going to repair GRUB, you should also check your EFI-boot-settings, this also can be the reason why GRUB isn’t booting. Just check our forum for those settings.”

I got the impression from OP that your EndeavourOS is bootable anyways. And If the above also means that your can boot up your install, then please boot into your EnOS, open a terminal an run the following commands. Copy the terminal output as text, paste it into your reply, highlight it and and click on </> to format.

efibootmgr -v

sudo parted -l

cat /etc/default/grub

pacman -Qi os-prober

efibootmgr
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0000,0002,2001,2002,2003
Boot0000* Windows Boot Manager	HD(2,GPT,ed4424c3-4f68-49fc-8b1b-6d4ba03e60dd,0xfa000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...0................
Boot0001* Unknown Device: 	MemoryMapped(11,0x670d3000,0x67790fff)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0002* HDD: TOSHIBA MQ01ABF050	PciRoot(0x0)/Pci(0x11,0x0)/Sata(0,0,0)/HD(6,GPT,3d8a60a1-513b-b945-80bb-79d3c84a8024,0x274c3000,0x190000)RC
Boot0003* Unknown Device: 	MemoryMapped(11,0x670d3000,0x67790fff)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0004* Unknown Device: 	MemoryMapped(11,0x670d3000,0x67790fff)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot0005* manjaro	HD(2,GPT,ed4424c3-4f68-49fc-8b1b-6d4ba03e60dd,0xfa000,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot0006* EndeavourOS	HD(6,GPT,3d8a60a1-513b-b945-80bb-79d3c84a8024,0x274c3000,0x190000)/File(\EFI\EndeavourOS\grubx64.efi)
Boot000C* Unknown Device: 	MemoryMapped(11,0x670d3000,0x67790fff)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot000D* Unknown Device: 	MemoryMapped(11,0x670d3000,0x67790fff)/FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)RC...0
Boot000E* ATAPI CDROM: HL-DT-ST DVDRAM GUE1N	PciRoot(0x0)/Pci(0x11,0x0)/Sata(1,0,0)/CDROM(1,0x5c3,0xb40)RC
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

sudo parted -l :

Model: ATA TOSHIBA MQ01ABF0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  524MB  523MB   ntfs            Basic data partition          hidden, diag
 2      524MB   629MB  105MB   fat32           EFI system partition          boot, esp
 3      629MB   646MB  16.8MB                  Microsoft reserved partition  msftres
 4      646MB   333GB  333GB   ntfs            Basic data partition          msftdata
 8      333GB   338GB  4241MB  linux-swap(v1)                                swap
 6      338GB   338GB  839MB   fat32                                         boot, esp
 7      338GB   500GB  161GB   ext4
 5      500GB   500GB  585MB   ntfs                                          hidden, diag

cat /etc/default/grub :

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="EndeavourOS"
GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 nowatchdog"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y
GRUB_DISABLE_SUBMENU=y

# To enable usage of os-prober, set GRUB_DISABLE_OS_PROBER to 'false'.
# Note: enabling os-prober creates a potential security risk!
# More info: https://www.gnu.org/software/grub/manual/grub/grub.html
GRUB_DISABLE_OS_PROBER=true

pacman -Qi os-prober :

Name            : os-prober
Version         : 1.79-1
Description     : Utility to detect other OSes on a set of drives
Architecture    : x86_64
URL             : https://joeyh.name/code/os-prober/
Licenses        : GPL3
Groups          : None
Provides        : None
Depends On      : sh
Optional Deps   : None
Required By     : None
Optional For    : grub  grub-tools
Conflicts With  : None
Replaces        : None
Installed Size  : 57.05 KiB
Packager        : Levente Polyak <anthraxx@archlinux.org>
Build Date      : Sat 17 Jul 2021 10:40:38 PM EEST
Install Date    : Fri 27 Aug 2021 02:17:09 AM EEST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Edit: in the first command theres something related to Manjaro, my previous linux installation, do I get rid it of it or something?

Let’s try a couple of things:

If you don’t have Manjaro anymore, remove its efi boot entry:

sudo efibootmgr -b 0005 -B

Now this seems a bit off to me. You have an efi boot entry 0006 for EndeavourOS but it doesn’t show in:

BootOrder: 0000,0002,2001,2002,2003

You could try:

sudo efibootmgr -o 0006,0000,0002,2001,2002,2003

to see if you can set a new bootorder including EnOS.

For your Windows Boot Manager to show up as boot option in Grub boot menu, you would need to edit /etc/default/grub and change

GRUB_DISABLE_OS_PROBER=true

to

GRUB_DISABLE_OS_PROBER=false

After editing and saving the file, you need to regenerate the grub.cfg:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Hopefully now if we get the boot order back in order so you should be able to see Grub’s boot menu after reboot.

1 Like

Removed the manjaro efi boot entry, then ran the second command including endeavour like you said:

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0006,0000,0002,2001,2002,2003
Boot0000* Windows Boot Manager
Boot0001* Unknown Device:
Boot0002* HDD: TOSHIBA MQ01ABF050
Boot0003* Unknown Device:
Boot0004* Unknown Device:
Boot0006* EndeavourOS
Boot000C* Unknown Device:
Boot000D* Unknown Device:
Boot000E* ATAPI CDROM: HL-DT-ST DVDRAM GUE1N
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

then, I nano’ed into /etc/default/grub
and changed the value to false, then i regenerated the grub config. file and I’m going to reboot now, but does it matter if the Boot0005 is skipped?

No. It was Manjaro’s which is already gone.

Alright, I also just restarted, it took me straight back to windows, not grub boot manager sadly

One more thing you could try from within EnOS is to reinstall Grub’s bootloader. But frankly I don’t think it would make any difference since your EnOS being bootable indicates that its bootloader is intact.

Why the boot order doesn’t remain once you have set it? I don’t really know. Those few times I have come across such issues in forum, pointed to failing CMOS battery. I can’t tell for sure that might be your case as well.

Please wait for other forum members more in the know in this regard to chime in and assist you.

One other thing I notice is all those boot entries for Unknown Device. I don’t know what they are for.

I myself don’t know what these boot things are lol, but thanks for the help though, really appreciate it

1 Like

How many systems do you have installed?

Look at efibootmgr output.

Remove all the entries for systems not installed using
sudo efibootmgr -Bb [entry-num]

Now change the order using
sudo efibootmgr -o [entry-num],[entry-num],[entry-num], etc

If you want the option to boot from USB stick then put that first. It will skip to second entry if no USB found.

If you mess it up chroot into your EOS system, mount efi partition and re-install grub.
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS --recheck

Then make sure your boot order is correct again and update-grub.

UPDATE: I restarted Endeavour, and “Welcome to GRUB!” flashed for a split second, and then it took me to the usual screen to pick either EndeavourOS or the UEFI Settings, but this time, a Windows option was available, I do not know what caused this, but now it works, even though i restarted last tine i tried what you told me, thank you so much! Now I just have to change the order to Endeavour then the Windows Boot manager like @otherbarry mentioned, and it should work, apparently the Grub boot manager didn’t detect Windows, but by updating it with your following command it fixed it.

1 Like

That sounds great! I am glad you got it working now.
:enos_flag:

1 Like

Reboot - mother of all remedies. Do it twice if once doesn’t do the trick.

1 Like