How do I make my videos not play like tiktok edits when I resume them?

Happens on ANY chromium based application. Vesktop, vivaldi, etc. you name it. Had it on my Nobara installation, still have it here. Running it on Wayland on my Nobara install (that I have now replaced with EOS) didn’t fix it, and doing the same here simply doesn’t show the window. I’ve tried the command line argument --enable-features=VaapiVideoDecodeLinuxGL, while it made this bug stop happening every time I start a video, it still happens when I pause a video, go away for >2 minutes and come back and resume. It is using the “Render/3D” pipeline like all applications on my Intel GPU which is driving my display. This does not occur on separate video players like MPV. Please help me fix this.

i915 is the active kernel module and I am using Wayland (the applications in question run via XWayland).

vainfo output: https://0x0.st/XqEw.txt
vdpauinfo output: https://0x0.st/XqEx.txt

fixed it by setting the environment variable LIBVA_DRIVER_NAME=iHD