How do I enable geckolinux font rendering config files on endeavour os?

The creator of geckolinux gave these instructions for it ( , see reply to second post.) I followed them, i.e I moved the geckolinux plasma next config files to /etc/fonts and then linked them with ln -s to /etc/fonts/conf.d as the same name, then rebooted and nothing happened. How do I enable these config files to endeavouros? Some help would really be appreciated.

maybe rebuild your font cache

fc-cache -fv

Do I run it as sudo or as both sudo and without sudo?

Also, to apply them in EndeavourOS do I link them to the folder or paste them there? This may help you know which one is needed to apply them . Thanks in advance.

Honestly know nothing about this project or the need for it. As far as custom fonts go I’ve always just placed them in the $HOME/.local/fonts folder. Select them with lxapperance (for my WM) and wala fonts are set to what i want.

Hi. This right here is exactly what you need to do.

And it is exactly what the maintainer is referring to.

Jan 22, 2023


Hi there, you can download the .tar.gz from here (Github) for the GeckoLinux Gnome edition to see what changes are applied in /etc/fonts. But you can generally get acceptable results by setting the font style to Ubuntu with RGB subpixel rendering and slight hinting.

PS: Edited the quote a bit to add a little more info.


Is the maintainer referring to how to change the default font or how to apply his font config files?

Both? They are saying you can compare their config to the default config in order to replicate it, or you can just use the built-in fonts with a regular theme-changer.

I recommend you try the latter. Use lxappearance to set up everything with just a few clicks.

The creator also says this

The Linux font configuration system works by reading the options from the files in /etc/fonts/conf.d/ . There are additional config files available but not activated in /etc/fonts/conf.avail/ and /usr/share/fontconfig/conf.avail/ . Their names and contents generally describe how they affect font rendering. If a font config file is not already present on your system and you want to apply it then you need to create a link to it with the same numbered name in /etc/fonts/conf.d/ .

What does he mean by this? Where do I link these files from?

:thinking: Do you have lxappearance on your system, or are you on KDE?

they’re on KDE


@amethystgosling Please share a screenshot of what the font rendering currently looks like when you only use built-in KDE settings. I’m tryna see somthing. :face_with_monocle:

Here’s how it looks like in GeckoLinux

I checked in my /etc/fonts/conf.d, it only has a file named 30-metric-aliases.conf . The rest of the files with the same name as the geckolinux config files (10-rendering-options.conf and 58-family-prefer-local.conf) are not in the default endeavouros /etc/fonts/conf.d folder. Now what do I do?

From the looks of it, the Gecko Linux font rendering just seems to make the UI font bolder.

If it’s the boldness/brightness of the font that you’re seeking, use a bolder version of the font you like, maybe?

> Or is there something I’m missing?

As far as the files in /etc/grub and/or /etc/fonts are concerned, you’re going to have to do some reading. Because I know that you can copy and paste the Gecko Linux files into that folder using root privileges. But I don’t know if you need to do more in order to not only make it work, but also to not bork your system. ← You probably do. :eyes:

Font configuration:

1 Like

Thanks for the answer @ddnn ! I think someday I am going to read through the Arch wiki page and try to understand it. Right now, my mental health is very bad and it is really hard for me to focus. As a temporary solution, I will make my system fonts bolder. However, as I understand it, the changes won’t apply to Firefox webpages since they will use the same font and font weight as the website is providing and if the website doesn’t provide any fonts, then the browser will pick the fonts which as far I know (I have only checked the default fonts settings in firefox) the firefox browser doesn’t allow to select a bolder weight for the default fonts. Therefore, I think I will have to apply the GeckoLinux config files for the system to render all the font weights a bit bolder, so the changes also carry over to firefox webpages as well.

Here how the same Dolphin window looks like with Ubuntu Medium on EndeavourOS

I still feel like the text is darker on GeckoLinux even if the font boldness is lighter it than this screenshot.

Sorry to learn that you’re not feeling well. I hope you feel better quicker than expected.

Note that the link I sent was specifically for hinting. It’s not a long read. In fact, it’s probably less than you’ve typed/read from the beginning of this thread.

As for webpages, Firefox extensions can usually do just about anything.

Which extension do you recommend for this purpose?