How do I disable this audio device?

I want to disable this ‘DG2 audio controller’ but not sure what is the best way to achieve this. I checked my BIOS and found an onboard audio device, but that just got rid of the ‘built in audio’ controller. This DG2 is an intel audio device according to terminal output, but I’m not sure how to disable it.

Looking to do this on both EndeavourOS and my Debian machine.

1 Like

What says inxi -aA ?

  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0403
  Device-2: Intel DG2 Audio driver: snd_hda_intel v: kernel pcie:
    speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 04:00.0
    chip-ID: 8086:4f90 class-ID: 0403
  Device-3: Arturia MiniFuse 1 driver: snd-usb-audio type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3- chip-ID: 1c75:af80
    class-ID: fe01 serial: 8831400368061334
  Device-4: Creative Sound Blaster X4
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3- chip-ID: 041e:3278
    class-ID: 0102 serial: DF44C2B79E9C412C
  Device-5: Logitech BRIO Ultra HD Webcam driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-
    chip-ID: 046d:085e class-ID: 0102 serial: B3D0F167
  API: ALSA v: k6.6.32-1-lts status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

I thought perhaps you could blacklist its driver, preventing it to be loaded and disable it that way.
However it looks like that the same driver is used by another device so perhaps that’s not a good idea.

I’m afraid I don’t know how to it in another way.

Device 1 is the one I already disabled in my BIOS that appeared as ‘built in audio device’ in pavucontrol. Not sure why it doesn’t also disable Device 2.

Disabling the driver for Device 2 wouldn’t be an issue as far as I can tell. How can I do that?

It’s annoying because it automatically turns on at least once a day, so I’d like to put an end to that. It’s never going to be used anyway.

I suspect if you disable it by preventing the driver to be loaded, your Device 1, using the same driver will be disabled as well. That may not be what you want.

Anyways, here you can read about how to blacklist a module:

1 Like

DG2 should be referring to an Intel Arc device, so I’d assume that it’s the HDMI output if you have an Arc GPU?

Yes I have an Intel ARC GPU but I don’t use audio from the GPU.

This solution did the trick. Thank you sir.

1 Like

You are welcome! Glad it worked out!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.