How can i restore default i3 config?

Hello! I am new here, and am noob in wms.
I tried to change i3 config in etc file, nothing changed. Then, I read that I need to copy that config (etc) in specific path and then do changes, I did it and added just one exec command to prevent auto run firefox, and rebooted.
Now, I am running default i3 configuration and system says to me that I don’t have config file, even if I have it etc and my user directories.

How can I fix that?:weary:

This is probably not the best way, but one way is to remove the /etc config files you messed with (which you shouldn’t have). Remove any i3 related config files in your .config directory. Remove i3 and reinstall i3.

I would copy/paste from the Endeavour github.

I’m on my phone in an airport so I’m not digging for it right now, but I’m sure someone will be able to post it up, or you can look and find it as well.

1 Like

You know, deleting the system is not a solution.
Any time I get error + delete something?xD

Then fix it. Undo whatever you did.
If you didn’t edit system files and/or had made backups before editing them, this wouldn’t be an issue, would it ? Thats how you do things…work on your own copy of files so that you can just delete them and revert back to the defaults. I don’t know what you did…I’m just telling you something that would work.
Feel free to wait for better instructions.


i3 provides a tool called i3-config-wizard that generates a config file. If you rename your ~/.config/i3/config file to something else and restart i3, i3 will offer to generate a config file for you, if you agree, it will run i3-config-wizrd to do the job.

You can run man i3-config-wizard to learn how to use the tool.


if it endeavouros ? i3 config be in your home in .config. if enedeavouros i3 you will find on endeavouros github. if you mess with /etc you can get base i3 config from i3 wiki.

any change usr do on i3 config should be do in ( .config/i3 ) it be in the usr home dir


I did nothing to etc, one line of code from example, it didn’t change anything, then I removed this line.
I get i3 default bar when I reload my system AFTER created local config (in home/user/) and copied config from etc there, like in the instructions said.

If you did not edit the system config files, you can get a default copy by removing the i3 files from .config in your home directory. I think on first run it copies the configs over. If not, they will remain in either /etc/default or /etc/i3 or similar locations (check the wiki for locations) and you can copy them manually to your $HOME/.config/ locations.

1 Like

Removing i3 config from home directory didn’t help, bar is still like i3 default not configured.

I ran it, it generates default configuration, I need configuration which was made my endeavours, not i3 default config where is minimal setup

check /etc/skel for default configs

1 Like

I made a timeshift backup, back to it, bar problem stays

This is the file you need.

1 Like

Why I have different file in etc folder?

@Yurchicnice The file I just sent you is supposed to be in your ~/.config/i3/ directory. Download that file and name it as ~/.config/i3/config

i3 will use that file to override the default config in the /etc/ directory.


Just for the record, seems there is some confusion in this thread…

The file located in /etc/i3/config is the default config file. I would not mess with it. If something is wrong with your own config in your home folder it will still be able to fallback on the default i3 config so you can fix things.

i3 looks in either ~/.config/i3/config which is where the default eos config can be copied to or ~/.i3/config


Okay, again. I reinstalled Endeavouros OS, with i3, if I go to the /etc/i3/config I will get the same file as before with something like 200 lines of code with comments against big config file from github with 593 lines of code. How does it work? I assume, if I will copy this file from /etc/i3/ to my home directory, I will get the same issue again.

I even created repo to github with default config file I have in /etc/i3/config
Here’s the link:

When you install i3, i3 provides a set of configuration (some keybindings, etc.) by default. Those default configurations are found in /etc/i3/config.

However, a user can override or replace the default configurations if and only if they create another config file in their home directory ~/.config/i3/config.

If ~/.config/i3/config is present, the configuration inside that file is preferred over the one in /etc/i3/config

The file in this link is not meant to go into /etc/ directory. It is meant to be placed in your home directory.


In other words, please download the file in the link and then rename it to ~/.config/i3/config, and you will get back the default i3 configuration provided by endeavouros. To be honest, you did not have to go as far as to reinstall your OS to reset the configuration.