How can I get an app to bypass firewalld?

I’m running into a lot of trouble with firewalld. There is an app installed via flatpak (LocalSend) that won’t work with the firewall enabled.

I’m guessing because its a flatpak, I can’t find it in the app list either to let it bypass the firewall.

Nor is there an easy button to turn off FirewallD; Endeavour OS documentation says I need to enter in a command via terminal (which is not at all intuitive adn easy to remember).

I tried installing gufw, but I’m running into issues with that as well: it doesn’t autostart on startup, there’s no system tray icon (as there is in other distros),

Some guidance, suggestions, help would be appreciated.

SOLVED: Added two rules for the port, one for each protocol as I was told

It isn’t because it is a flatpak. It is because firewalld has a list of common services. When the thing you want to open isn’t on that common list, you need to add a new service for it via the UI.

You could create more permissive zone and switch to it via the GUI but that isn’t really the right solution.

The right solution is to identify which ports that application needs open and add a service for it in firewalld.

You can switch if you want to, but you will still have the same problem, you need to know which ports to open.

However, you should not have both firewalls installed. Either install ufw or firewalld, not both. Remove the one you don’t want.

1 Like

Ok, if its a port issue, I looked up the port number on the app; but firewalld is also asking for Protocol and i odn’t know what to fill out for that.

what’s the protocol associated with the app?

When the port is provided, the protocol should also be provided. It is specific to the application in question.

I’m being a little thick headed here, maybe its called something else

Here is the network settings section where I got the port number from, but there really doesn’t seem to be anything I can mark as protocol


It looks like you need to open both tcp and udp on that port.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.