How can I disable middle click pasting?

Hi, totally noob question I know!

The first result on Google comes up with:

Right click on desktop → Configure Desktop and Wallpaper… → Mouse Actions → Remove middle mouse pasting

This didn’t work. Middle click still pastes. I can’t move around in Figma for the life of me, because it pastes whatever link I copied like an hour ago. Is there any fix to this?

Hello. As you told that your previously copied link is still pasted when you execute mouse middle-click.
If you are on KDE Plasma, then the simple method is to clear your clipboard. By doing this middle-click will not paste the previously copied link. This issue applies to anything that is copied and is present on clipboard.
.
Middle click copy/paste is a default setting in Xorg Server.There is no option to disable this setting but you can change the working of middle-click.
.

If you need more context, then :

In that case, is there a convenient way to clean the clipboard?

Clipboard is present in system tray :


.
.
.Which can be cleared by pressing the clipboard :

Just press the brush icon to clear the entire clipboard history, or you can do selective removal of histories by using red colored delete icon.