How autostart Plank in Xfce?

Hi to all, I have a question, I use Endeavour Xfce, recently I installed Plank, but the app dont autostart and I cant find the option in system settings or Plank settings.

ty for your help and sorry for my english! :sweat_smile:

Xfce: Settings -> Session and Startup > Application Autostart

source:

5 Likes

Remember to remove shadows in windows manager tweaks in compositor. You will find it in settings. Otherwise you get big ugly shadows on Plank.

3 Likes

TY very much to you two!!
SOLVED!!!

4 Likes

fwiw, items got removed from Plank after every update and you have to add them again.
That was a reason for me to not use Plank anymore.
(I got myself a second panel and made it look like Plank.)

So do I. Plank is unnecessary when you can make panels look the same. Almost the same. In my opinion, they look better.

The left is Plank the right is Xfce panel:

3 Likes

I’ll try it, could you please tell me what exact options you use in that panel? I don’t know how to make the applications launch and minimize from the icons themselves.

And another silly question, in which folder should I put the icons I download? because thunar doesn’t let me log in as root by default, and if I open thunar from the console with root permissions (sudo thunar) when I copy the files then they don’t appear for me to choose.

Thank you in advance!

Translated with www.DeepL.com/Translator (free version)

I send up some screenshots so it’s easier to see. I’m not very good at English either!

This is what I have done:

Now you get started apps at the bottom without text. Just icons.

Looks like this:

For icons, you can create an .icons folder in your home and then put the icons in it.

If you install things as root then they belong to root, not you the user. This is why the icons should go in your home folder. If the above doesn’t work the put the icons folder in .local/share/ and remove the dot from the icons folder.

1 Like

ty for the tip!

Awsome! TY for show me it!! very good work mate!

TY for the tip! :slight_smile:

Here’s a little something that might help with the Thunar part of the problem. Just create a file called uca.xml in ~/.config/Thunar with (at least some of) the following contents. (I left some other stuff in there, and removed others for now)

uca.xml
<?xml encoding="UTF-8" version="1.0"?>
<actions>
<action>
	<icon>utilities-terminal</icon>
	<name>Open Terminal Here</name>
	<unique-id>1488955845049151-1</unique-id>
	<command>exo-open --working-directory %f --launch TerminalEmulator</command>
	<description>Example for a custom action</description>
	<patterns>*</patterns>
	<startup-notify/>
	<directories/>
</action>
<action>
	<icon>preferences-desktop-wallpaper</icon>
	<name>Set wallpaper dual</name>
	<unique-id>1526628754365261-1</unique-id>
	<command>nitrogen --save --set-zoom-fill %f</command>
	<description></description>
	<patterns>*</patterns>
	<image-files/>
</action>
<action>
	<icon>preferences-desktop-wallpaper</icon>
	<name>Set wallpaper single</name>
	<unique-id>1489091195323731-3</unique-id>
	<command>nitrogen --save --set-zoom-fill  --head=0 %f  &amp;&amp; nitrogen --set-zoom-fill  --head=1 %f</command>
	<description></description>
	<patterns>*</patterns>
	<image-files/>
</action>
<action>
	<icon>meld</icon>
	<name>Compare</name>
	<unique-id>1492232362549799-1</unique-id>
	<command>meld %F</command>
	<description></description>
	<patterns>*</patterns>
	<directories/>
	<other-files/>
	<text-files/>
</action>
<action>
	<icon>catfish</icon>
	<name>Search with catfish</name>
	<unique-id>1489089852658523-2</unique-id>
	<command>catfish --path=$f$d</command>
	<description></description>
	<patterns>*</patterns>
	<directories/>
</action>
<action>
	<icon>cs-startup-programs</icon>
	<name>Run</name>
	<unique-id>1526630606202525-4</unique-id>
	<command>xfce4-terminal -e %f</command>
	<description></description>
	<patterns>*</patterns>
	<other-files/>
	<text-files/>
</action>
<action>
	<icon>system-file-manager-root</icon>
	<name>Open folder as root</name>
	<unique-id>1493475601060449-3</unique-id>
	<command>pkexec thunar %f</command>
	<description></description>
	<patterns>*</patterns>
	<directories/>
</action>
<action>
	<icon>ktexteditorautobrace</icon>
	<name>Edit as root</name>
	<unique-id>1526631419798289-11</unique-id>
	<command>gksudo featherpad %F</command>
	<description>edit as root</description>
	<patterns>*</patterns>
	<text-files/>
</action>
</actions>

Hope it (they) help…