Horrible microphone quality

My laptop’s microphone has a terrible static noise, no matter what I record. I know I fixed this issues a few months ago by using someone’s daemon.conf, but I can’t for the life of me find it again. Anyone know how to fix it? I’ve tried the method from arch wiki.

some hardware info would be great :wink:
inxi -Fxxc0z --no-host | eos-sendlog

Thank you. I never know which commands to share in these situations

arecord -l
will list the input devices and info.
As everyone is switching to pipewire I can recommend to try that, it solves a lot of this little nasty issue with pulseaudio…

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3202 Analog [ALC3202 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Make sure you have alsa-utils installed, launch alsamixer, then select your audio device (pressing F6), navigate all the way left using the left arrow, and stop on Loopback, if Enabled disable it using the down arrow. This should not impact audio playback or microphone recording negatively, unless you require loopback mixing.

Is this what you try already?

I haven’t. But I just installed pipewire, which mostly solved the problem, even though some static noise still persists. Is pulseaudio now uninstalled?

pipewire-pulse replacing it… to be able to use stuff build for pulse :wink: what I mean is stuff like audiomixer from pulseaudio are still in use.

but alsamixer is a good start to check for these loopback settings… in some cases alsamixer has also switches for stuff like microphone amplification e.t.c that can help

1 Like

Btw, after checking pipewire wiki page, I don’t seem to have a pipewire directory in my /etc. Is that normal?

Worked like a charm. Thank you.

holds configs/examples
as it is running on userlevel

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.