Horizon Zero Dawn Joystick or Gamepad support

I want to play Horizon Zero Dawn, purchased the Gog Version. So installed it via Heroic and started the game, everything looks great, runs smooth no crashes.
Then i had the great idea i want to play via my DS4 Controller, so plugged it into my PC, but I could not get it to work with this specific game. If I use programs like sc-controller the game crashes after a few minutes, every time. I checked the controller in the system settings all works, checked the controller in wine control all fine, even rumble works. Added xinput with winetricks, no changes.
I already wasted a few hours with this problem.

Maybe somebody had a similar issue with another game or exactly the same game. I don’t want to crawl back to Win10 for joystick support.

Some games straight up don’t work. If the game already has controller issues on windows. It only gets worse on linux. I did a quick Google search for controller issues with that game on Windows and there are countless reddit results that seem to have that issue on Windows and a variety of things that work for some and not others. While I did not spend too much time going down this rabbit hole. One thing I read on a Reddit thread that seemed to work for one person was to enter the overworld via keyboard and mouse and then start using the controller. They said to never use it in the menu. Anyways. I don’t have the game, so I am not sure if the problem is solvable.

Thank you, I tried it, but no success.
Installed the game under win10 and the controller just works great. I really like Linux, and I am amazed how much games are working so great, but some things are still not that good, like controller support, don’t know why.

I meant to ask but did you try running the game via steam as a non steam game to see if Proton would fix the issue?

I have tried that, but it did not work. I have also tried proton-ge and wine-ge, but both did not work. At Friday I will try a Bluetooth dongle instead of usb, but my hopes are low.

i’m about to install the game and see if i can get it to work myself.

I used sc-controller and that made the controller work. The game has not crashed for me. Not yet at least. I haven’t made it past the intro movie yet, but I’ll let you know what happens when I get to the actual game play.

For whatever reason the game only launches using regular wine, steam wouldn’t launch it at all. Anyways, it worked even during gameplay without crashing using sc-controller. I tried both wired and via bluetooth. Both worked fine for me.

After a bit more testing, sc controller seems to work better with bluetooth than through wired. For example if the wired connection is interrupted for any reason. sc controller and the game no longer recognize the controller. However with bluetooth. I just turn the controller back on and it kept working without having to restart the game or sc-controller.

Since sc-controller works for me without crashing. Let me know what error you are getting.

1 Like

Thank you very much. I have only tried usb with sc-controller, but the game crashes after a few minutes. The Bluetooth dongle was delivered yesterday. I was able to establish a connection, but it does not work yet, so I have to solve this problem first.

Can’t even get my DS4 to work via Bluetooth. Installed blueman, enabled Bluetooth, paired the DS4 controller, but no input. Can’t get my system to generate a joydev. Struggled to find a solution for the last few hours. Linux is a mystery, sometime everything works great, and sometimes I just can’t figure out why it does not work.

@d-air1 Finally worked out the bluetooth problem, different topic, but when i start the game with sc-controller it crashes after a few minutes.

What error happens when it crashes though? A random guess is maybe sc-controller needs to be rebuilt or something?

I’ve got this version from the AUR:


If it is possible then I call the system monitor and end the task of the game, if not I just reboot. I don’t know which message I get during a crash. Is there a way to read the logs?

Have the same version of sc-controller and I rebuilt it, but the game still crashes.

Launch the game from the terminal and when it crashes. Copy and paste the terminal output here. Maybe something there will be useful…