High FPS but minor stuttering

Hi everyone! Before i get started just wanted to let everyone know i GREATLY appreciate all replies, thank you so much! So i decided to move to Linux semi-permanently and only switch off to Windows when i absolutely can’t figure out a problem. I mostly have experience with Fedora and it’s fair to say i’m all around not 100% confident in my Linux abilities yet but im figuring it out fairly quick. Anyways, Every game i’m playing i’m getting really high FPS even higher than windows i’m genuinely shocked. But i have moments where my screen just freezes for 2-10 seconds sometimes. I’ve been playing a ton of Team Fortress 2 the last 3 weeks and this obviously gets me killed in a FPS game alot. I originally had thought it was just a TF2 issue because the game is old and even on windows i have to tweak and tinker with it. But after trying a bunch of other native games such as Black Mesa, Barony and Counter Strike 2 i get the same issues. I have read through the EndeavourOS page on optimizing the system and installing “Vulkan Drivers” and what not and id be lying if i said i wasn’t completely confused. I’m running the default drivers that came on the system are these considered vulkan by default or no? I’ll leave my specs down below but id really appreciate some help my system is genuinely so close to being better than my windows one i’m so impressed i’m determined to make Linux my new home.

OS Specs:
noggingnome@localhost ~]$ neofetch

OS: EndeavourOS Linux x86_64
Host: B650E PG-ITX WiFi
Kernel: 6.6.7-arch1-1
Uptime: 4 hours, 50 mins
Packages: 1199 (pacman), 182 (flatpa
Shell: bash 5.2.21
Resolution: 1920x1080
DE: GNOME 45.2
WM: Mutter
WM Theme: Shades-of-purple
Theme: Adwaita-dark [GTK2/3]
Icons: Qogir-dark [GTK2/3]
Terminal: gnome-terminal
CPU: AMD Ryzen 7 7700X (16) @ 5.573G
GPU: AMD ATI Radeon RX 6700/6700 XT/
GPU: AMD ATI 12:00.0 Raphael
Memory: 6573MiB / 15103MiB

If you play with steam then all those drivers and dependencies should have been pulled by default ,
Still you can try running this command:

sudo pacman -S --needed lib32-mesa vulkan-radeon lib32-vulkan-radeon vulkan-icd-loader lib32-vulkan-icd-loader

These two things should help,I dont know about this but you can try this as well:

sudo pacman -S linux-zen linux-zen-headers

Did you use the terminal or what to install steam ?

did you try proton-ge with the zen kernel? Did you turn on shader pre caching?

My suspicion:

Few months/weeks ago there is discussion regarding how Native Linux programs could behave more erratically than Proton-ized Games on Steam. OP listed few games that has Native version.

So, possible “solutions”:

  1. Reinstall the game, but install with Proton forced ON. Meaning you’re installing windows version of the game with proton.
  2. Always always always, check protondb for possible tweaks.
  3. IF you made sure that the game you installed are proton version of the game, try switching Proton version, experimental or the current latest version, if you still get the error, try proton-ge
  4. Try playing the game on X11 instead of Wayland (GNOME defaulted to Wayland, click the gear button when logging in).


why your RAM usage is at 6 GB, that’s half of the highway being used? GNOME on idle is about 2GB or RAM usage, insufficient RAM could also led to hitches.