Hibernate stopped working on Jun 04

Hey, I have a problem with hibernation. It worked fine until Jun 04. But suddenly (some update I guess) all screens go black, the storage led blinks for some seconds and then the PC completely freezes. the log with sudo journalctl -ru systemd-hibernate.service Only shows two lines:

Jun 08 13:34:16 Alohomora systemd-sleep[23259]: Entering sleep state 'hibernate'...
Jun 08 13:34:16 Alohomora systemd[1]: Starting Hibernate...

Previous Hibernations showed more lines:

Jun 04 12:42:22 Alohomora systemd[1]: systemd-hibernate.service: Consumed 9.046s CPU time.
Jun 04 12:42:22 Alohomora systemd[1]: Finished Hibernate.
Jun 04 12:42:22 Alohomora systemd[1]: systemd-hibernate.service: Deactivated successfully.
Jun 04 12:42:18 Alohomora systemd-sleep[2191740]: System returned from sleep state.
Jun 03 18:32:14 Alohomora systemd-sleep[2191740]: Entering sleep state 'hibernate'...
Jun 03 18:32:14 Alohomora systemd[1]: Starting Hibernate...

I am using a Nvidia GTX 1070ti and enabled preserving its memory when hibernating. Otherwise discord always crashes after hibernation. I disabled that by removing /etc/modprobe.d/nvidia-power-management.conf with following content and hibernation worked again:

options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp

The log sudo journalctl -ru nvidia-hibernate.service does not show any errors:

Jun 08 14:20:19 Alohomora systemd[1]: Finished NVIDIA system hibernate actions.
Jun 08 14:20:19 Alohomora systemd[1]: nvidia-hibernate.service: Deactivated successfully.
Jun 08 14:20:18 Alohomora logger[3965]: <13>Jun  8 14:20:18 hibernate: nvidia-hibernate.service
Jun 08 14:20:18 Alohomora hibernate[3965]: nvidia-hibernate.service
Jun 08 14:20:18 Alohomora systemd[1]: Starting NVIDIA system hibernate actions...

General Info:
EndeavourOS with i3wm
Zen Kernel 6.3.6
AMD Ryzen 5900x
Nvidia GTX 1070ti


  • To Swap partition (33 GB)
  • Resume=UUID=… set correctly in systemd-boot
  • worked fine for months

Any ideas what the problem could be or how I can investigate further?

Thanks in Advance!

Update: I tested a bit more and sometimes it even fails after I disabled the nvidia memeory preserving.


That link is also in the arch wiki page I linked. So I am not sure why you linked me that? There is no additional information nor information about debugging. As I stated it worked for a while. So my config was fine. Some update broke it but I do not know ways to debug whats happening.

Because it isn’t a direct link and i don’t have a habit of going back looking through other posted topics. How would i know what you have done or haven’t done. :unamused:

Only here to try to help. :man_shrugging:

I have some updates: I disabled the nvidia PreserveVideoMemory feature and still something is completely broken. Even suspend is broken now. Sometimes the PC does not even turn off but screens turn off and gets unresponsive. Sometimes suspend works but resuming from suspend does not work. Hibernate the same. Sometimes it works normally. Most of the time the PC does not shut down. sometimes it does shut down but freezes on resume.

I am really lost. No idea how to debug this.