Hibernate option fails to show on xfce

On my tower computer this has worked fine but when I do the exact same thing on my laptop it fails to work.

So I have done the following to create a swapfile.

sudo fallocate -l 16G /swapfile
sudo chmod 600 /swapfile
sudo mkswap /swapfile

Then I did this:

sudo nvim /etc/fstab

And added this line:
/swapfile swap swap defaults 0 0

And restarted.

Regardless if I add add inside /etc/default/grub the resume and resume_offset and add this line add_dracutmodules+=" resume " to /etc/dracut.conf.d/resume.conf, I should get an option on xfce to hibernate but I don’t.

On the power options when I set the close lid to hibernate. I get an error message which states that there is not enough swap space to perform hibernation.

I have got 16 GB of RAM on my laptop so I allocated 16 GB of swapspace. I am not too sure why on my tower computer this works but on my laptop computer this fails, they both have 16 GB of RAM?

you can clearly verify this info.

Can you manually hibernate the system with sudo systemctl hibernate?

No i get an error message:

Call to Hibernate failed: Not enough swap space for hibernation

Can you share the output of cat /proc/cmdline

I F’d something up I put in the wrong partition in the /etc/default/grub file, after fixing it and rebuilding it and rebooting, it now works, it even shows on the xfce settings!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.