Help with Steam gaming (AMDGPU/Vulkan)


Looking for help after performing a system update. Steam games are no longer launching. I had been using the mesa-git drivers, and have downgraded to mesa, tried re-installing drivers, to no avail.
Searching online revealed no help, and it seems like everything should work, however I get this error when running: vulkaninfo

WARNING: [Loader Message] Code 0 : terminator_CreateInstance: Failed to CreateInstance in ICD 0. Skipping ICD. Segmentation fault (core dumped)

Thanks for looking!

results of inixi -Fza

  Kernel: 6.0.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
    root=UUID=a834b639-ab1f-4283-bcb2-8d00eca49a84 rw radeon.si_support=0
    amdgpu.si_support=1 loglevel=3 nowatchdog nvme_load=YES
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: P8Z68-V v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 3603
    date: 11/09/2012
  Info: model: Intel Core i7-2600K bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1677 high: 2026 min/max: 1600/5900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1647 2: 1600 3: 1648
    4: 2026 5: 1648 6: 1648 7: 1600 8: 1600 bogomips: 56039
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] vendor: ASUSTeK
    driver: amdgpu v: kernel alternate: radeon arch: GCN-1
    code: Southern Islands process: TSMC 28nm built: 2011-20 pcie: gen: 2
    speed: 5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
    active: DP-2,DP-3 empty: DP-1, DP-4, DVI-D-1, DVI-I-1 bus-ID: 01:00.0
    chip-ID: 1002:6798 class-ID: 0300 temp: 42.0 C
  Display: x11 server: X.Org v: 21.1.5 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4000x2560 s-dpi: 96 s-size: 1058x677mm (41.65x26.65")
    s-diag: 1256mm (49.45")
  Monitor-1: DP-2 mapped: DisplayPort-1 pos: top-left model: Gigabyte M27Q
    serial: <filter> built: 2021 res: 1440x2560 dpi: 109 gamma: 1.2
    size: 335x596mm (13.19x23.46") diag: 801mm (31.5") ratio: 16:9 modes:
    max: 2560x1440 min: 640x480
  Monitor-2: DP-3 mapped: DisplayPort-2 pos: primary,bottom-r
    model: Gigabyte M32Q serial: <filter> built: 2022 res: 2560x1440 dpi: 93
    gamma: 1.2 size: 698x393mm (27.48x15.47") diag: 801mm (31.5") ratio: 16:9
    modes: max: 2560x1440 min: 720x400
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: AMD Radeon R9 200 / HD 7900
    Series (tahiti LLVM 14.0.6 DRM 3.48 6.0.12-zen1-1-zen) direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Device-2: AMD Tahiti HDMI Audio [Radeon HD 7870 XT / 7950/7970]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
    chip-ID: 1002:aaa0 class-ID: 0403
  Sound API: ALSA v: k6.0.12-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.63 running: yes
  Device-1: Intel 82579V Gigabit Network vendor: ASUSTeK P8P67 Deluxe
    driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1503
    class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: ASUSTek Bluetooth Adapter type: USB driver: btusb v: 0.8
    bus-ID: 2-1.7:5 chip-ID: 0b05:179c class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 3.87 TiB used: 239.05 GiB (6.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS250G1B0A-00H9H0 size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 10WD
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD40EZAZ-19SF3B0 size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 0A80 scheme: GPT
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 37.62 GiB (16.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 3.64 TiB size: 3.58 TiB (98.40%)
    used: 201.43 GiB (5.5%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 12 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 32.0 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (RPM): N/A
  Processes: 222 Uptime: 11m wakeups: 0 Memory: 7.73 GiB
  used: 3.06 GiB (39.5%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 16.0.0 Packages: pm: pacman
  pkgs: 1312 libs: 430 tools: yay Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.24

Do you have the vulkan packages installed?

I seem to be seeing libx11 causing some issues… maybe this is causing your issue too? It was just updated in the last few days.

Here is the bug report

ricklinux - yes vulkan packages are installed. Even re-installed everything I thought may have been related…

Goldenk - Maybe libx11 is the issue. I have tried running Steam(Native) instead of Steam(Runtime) and everything seems to be working at this time.

I will mark as solved for now. Thanks for the replies!

1 Like

That doesn’t explain why you have no output for vulkaninfo. I get a huge amount of output.

Edit: See the output here.

So I am using the libx11 1.8.3-3 on Arch testing(I actually don’t use EOS but use vanilla Arch) this update that just released today fixed my game issue. However, ricklinux makes a good point. Hopefully everything work out for you.

Do you have this setting in


options amdgpu si_support=1
options amdgpu cik_support=1

Edit: Also in /etc/mkinitcpio.conf

MODULES=(amdgpu radeon)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.